Bug 60628 - The installer crashed at the moment it wants to show the package list.
The installer crashed at the moment it wants to show the package list.
Status: CLOSED NOTABUG
Product: Red Hat Public Beta
Classification: Retired
Component: kernel (Show other bugs)
pensacola
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-03-03 05:02 EST by Jan Gerrit Kootstra
Modified: 2007-04-18 12:40 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-03-06 23:01:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
The crashdumpfile from anaconda (46.47 KB, text/plain)
2002-03-03 05:04 EST, Jan Gerrit Kootstra
no flags Details

  None (edit)
Description Jan Gerrit Kootstra 2002-03-03 05:02:38 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.78 [en] (X11; U; Linux 2.4.9-31enterprise i686)

Description of problem:
The installer shows a message that it has detected an error, probably an
anaconda bug.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. go into text mode installation
2. follow the installation for advanced server with all languages chosen or
Dutch(NL) and English(USA)
3. use automatic partitioning
	

Actual Results:  Get a crashdump

Expected Results:  A package list should appear

Additional info:

The installation is tried on an IBM 2133-571 with a intel 80486DX 33 MHz
processor, 64MB internal memory and 4GB harddisk.

A crashdump can be send, but is to big to copy here without errors.
Comment 1 Jan Gerrit Kootstra 2002-03-03 05:04:54 EST
Created attachment 47240 [details]
The crashdumpfile from anaconda
Comment 2 Jan Gerrit Kootstra 2002-03-03 05:22:19 EST
Please, ignore the remark about not being able to add the crashdump.
Comment 3 Jan Gerrit Kootstra 2002-03-03 05:23:06 EST
Tried to do an Custom Install and got the same crashdump.
Comment 4 Soren C. Sorensen 2002-03-05 18:51:33 EST
I have the same problem:

My set up: pentium 133, 128 MB RAM, Packard Bell D135 (hillary mainboard), 8.4 
gig Western Digital drive, "NEC CDROM:282". Booted with floppy, 1st cd in cdrom 
drive on local machine.

On the first attempt I pressed enter at the "boot:" prompt for the default 
install mode, using English as the installation language, selected a custom 
install, and partitioned my disk manually with disk druid.

On the second attempt I entered text at the "boot:" prompt and proceeded as 
before.

On the last attempt I went with a default install method, the default system 
(vs. a custom system) and autopartitioned.

On all three occasions it failed in the same spot, but the text install shows 
the installer is loading packages when it fails and graphical mode appears mor 
abrupt.

The file on the floppy created after this crash crash is called anacdump.txt 
and begins: (excerpts typed by hand...)

Traceback (innermost last):
 File "/usr/bin/anaconda", line 620, in ?
  intf.run(id, dispatch, configFileData)
 File "/usr/lib/anaconda/gui.py" line 350, in run
  self.icw.run(id, dispatch, configFileData)
 File "/usr/lib/anaconda/gui.py" line 782, in run
  mainloop ()
 File "/usr/lib/python1.5/site-packages/gtk.py", line 2608, in mainloop
  _gtk.gtk_main()
 File "/usr/lib/python1.5/site-packages/gtk.py", line 125, in __call__
  ret = apply(self.func, a)
**etc,until:
KeyError: kernel

Local variables in innermost frame:
self: (comps.HeaderListFromFile instance at 84ebf20)
item: kernel

Individual package selection status:
4suite: 0, Canna: 0, Canna-devel: 0 **etc, etc
-----------

Immediately after this occurered I successfully installed Seawolf on this 
machine without any obvious problems.

Comment 5 Jan Gerrit Kootstra 2002-03-06 00:45:54 EST
For your information: Enigma (RH 7.2) works fine without X-Windows on the IBM
PS/1 model 2133-571
Comment 6 Jeremy Katz 2002-03-06 23:01:47 EST
This is because the kernel is being built without an i586 or an i386 variant and
thus it can't find a kernel that will work on your system.  Reassigning to kernel
Comment 7 Jay Turner 2002-04-23 14:07:26 EDT
The Advanced Server release is intended for only i686 and above processors, so
this isn't a bug.  Closing out.

Note You need to log in before you can comment on or make changes to this bug.