Bug 60629 - autorun is unable to start kscd
Summary: autorun is unable to start kscd
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: autorun (Show other bugs)
(Show other bugs)
Version: 7.2
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Harald Hoyer
QA Contact: Aaron Brown
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-03-03 11:01 UTC by Leonid Kanter
Modified: 2007-04-18 16:40 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-03-04 15:34:01 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch for described problem (2.22 KB, patch)
2002-03-04 15:18 UTC, Andy Shevchenko
no flags Details | Diff
This patch I will use... (1.41 KB, patch)
2002-03-04 15:33 UTC, Harald Hoyer
no flags Details | Diff

Description Leonid Kanter 2002-03-03 11:01:47 UTC
Description of Problem:

autorun is unable to start kscd because it pass wrong argument

Version-Release number of selected component (if applicable):

autorun-2.7-1
kdemultimedia-2.2.2-2

How Reproducible:

always

Steps to Reproduce:
1. start kde, then open konsole and type "killall autorun"
2. start new autorun in konsole: type /usr/bin/autorun -l --interval=1000
--cdplayer=/usr/bin/kscd
3. insert audio cd

Actual Results:

You'll see following:

kscd: Wrong argument '/dev/cdrom'.

Expected Results:

kscd must start silently

Additional Information:
	
Either /dev/cdrom argument must be disabled in autorun or kscd must ignore this
argument.

Comment 1 Andy Shevchenko 2002-03-04 15:17:16 UTC
I have wrote the patch that fix the described problem.



Comment 2 Andy Shevchenko 2002-03-04 15:18:40 UTC
Created attachment 47340 [details]
patch for described problem

Comment 3 Harald Hoyer 2002-03-04 15:33:57 UTC
Created attachment 47341 [details]
This patch I will use...

Comment 4 Andy Shevchenko 2002-03-04 15:46:29 UTC
I think your patch do not safe functionality of autorun program.
You can not pass the device parameter to external program if you installed 2 CD
ROM drivers into your PC and want to use second CD ROM for listen audioCD.
I propose to use additional option (as I wrote in my patch).


Comment 5 Harald Hoyer 2002-03-04 15:49:49 UTC
$ autorun --help
Usage: autorun [OPTION...] [cdromdevices...]
.....
Command strings are parsed and %P% is replaced by the mountpoint path.
%D% is replaced by the device path. After that the command string will be
executed using /bin/sh -c "command string".
...

This now works also for 
$ autorun --cdplayer="myaudiocdplayer %D%"



Note You need to log in before you can comment on or make changes to this bug.