Bug 60647 - not all files are displayed when running linux nfs client
Summary: not all files are displayed when running linux nfs client
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: nfs-utils   
(Show other bugs)
Version: 7.2
Hardware: i686 Linux
medium
high
Target Milestone: ---
Assignee: Pete Zaitcev
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-03-04 03:09 UTC by Kevin Moore
Modified: 2007-04-18 16:40 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-03-13 15:28:12 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Kevin Moore 2002-03-04 03:09:51 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.01; Windows NT)

Description of problem:
When running nfs client and mounting an export from a HP700 server running HP-
UX, not all files are always displayed within mounted directories.

Version-Release number of selected component (if applicable):


How reproducible:
Sometimes

Steps to Reproduce:
1.mount an nfs export
2.do an "ll" or view the mount from nautilus
3.
	

Actual Results:  Certain directories (usually ones with more than 300 files) 
report 0 items found in the directory.

Expected Results:  Correct file counts to be reported

Additional info:

The client machine is an HP Vectra Vli8 with a 3Com 3c905b NIC. I have another 
identical machine running Redhat Linux 6.1 which performs this same task with 
no problem, it also has a 3Com 3c905b NIC. I have tried changing read and write 
sizes to 1024, as well as many other trial read and write sizes to no avail. I 
have used Redhat Network to update the 7.2 kernel to 2.4.9-31, as well as 
updateing all installed packages, nfs-utils included.

Comment 1 Bob Matthews 2002-03-11 22:02:47 UTC
Can you try the latest kernel from RAWHIDE?

ftp.redhat.com:/pub/redhat/linux/rawhide/i386/RedHat/RPMS/

Comment 2 Kevin Moore 2002-03-13 15:28:07 UTC
The 2.4.17-0.18 Rawhide kernel seems to have fixed the nfs client issue. Do you 
know what the problem is with 2.4.7-10 and 2.4.9-31?

Comment 3 Bob Matthews 2002-03-13 15:42:35 UTC
There were a large number of nfs related bug-fixes added to the kernel between
2.4.10 and 2.4.18.  I suspect one of these addressed the problem you were
seeing.


Note You need to log in before you can comment on or make changes to this bug.