Bug 606474 - libguestfs requires .hmac files not provided by updated openssl
libguestfs requires .hmac files not provided by updated openssl
Status: CLOSED DUPLICATE of bug 604307
Product: Fedora
Classification: Fedora
Component: libguestfs (Show other bugs)
12
All Linux
low Severity medium
: ---
: ---
Assigned To: Richard W.M. Jones
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-21 14:13 EDT by Alex Villacís Lasso
Modified: 2010-07-01 06:21 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-01 06:21:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Alex Villacís Lasso 2010-06-21 14:13:03 EDT
Description of problem:
When trying to update to openssl-1.0.0a-1.fc12 , I get the following failed dependency messages (in Spanish):
Errores de la resolución de dependencias:

Paquete: 1:libguestfs-1.0.85-1.fc12.3.x86_64 (@updates)
    Necesita: /usr/lib64/.libssl.so.1.0.0.hmac
    Eliminando: openssl-1.0.0-4.fc12.x86_64 (@updates)
    Disponible: openssl-1.0.0-0.10.beta3.fc12.x86_64 (fedora)
Paquete: 1:libguestfs-1.0.85-1.fc12.3.x86_64 (@updates)
    Necesita: /usr/lib64/.libcrypto.so.1.0.0.hmac
    Eliminando: openssl-1.0.0-4.fc12.x86_64 (@updates)
    Disponible: openssl-1.0.0-0.10.beta3.fc12.x86_64 (fedora)

Version-Release number of selected component (if applicable):
libguestfs-1.0.85-1.fc12.3.x86_64
openssl-1.0.0a-1

How reproducible:
Always

Steps to Reproduce:
1. Install libguestfs and required packages with older openssl
2. Attempt to upgrade to newest openssl
3.
  
Actual results:
RPM dependency failures, unable to update normally

Expected results:
No dependency failures. Update should proceed normally.

Additional info:
[alex@srv64 ~]$ rpm -q --requires libguestfs |grep hmac
/lib64/.libgcrypt.so.11.hmac  
/usr/lib64/.libcrypto.so.1.0.0.hmac  
/usr/lib64/.libcrypto.so.10.hmac  
/usr/lib64/.libssl.so.1.0.0.hmac  
/usr/lib64/.libssl.so.10.hmac
Comment 1 Fabrice Robin 2010-06-22 04:14:20 EDT
Same problem here.

But, to me, this is a critical severity and high priority as all my network users spread around the world cannot update "easily" their Fedora 12 OS for a week now. (Yes they all use virtualization through libguestfs tools on their machines every day and yes most of them are not linux friendly...I'm not helped ;-)).

Thank you for your work on libguestfs that is a wonderful tool.
Comment 2 Fabrice Robin 2010-06-23 10:51:21 EDT
(In reply to comment #1)
> Same problem here.
> 
> But, to me, this is a critical severity and high priority as all my network
> users spread around the world cannot update "easily" their Fedora 12 OS for a
> week now. (Yes they all use virtualization through libguestfs tools on their
> machines every day and yes most of them are not linux friendly...I'm not helped
> ;-)).
> 
> Thank you for your work on libguestfs that is a wonderful tool.    

Oups duplicate of Bug 604307 which is fixed in repo updates-testing
Comment 3 Richard W.M. Jones 2010-07-01 06:21:08 EDT
Latest builds of libguestfs are available here:

http://koji.fedoraproject.org/koji/packageinfo?packageID=8391

We generally notice dependency problems like this and fix
them very quickly, so if in doubt, check that list first.

*** This bug has been marked as a duplicate of bug 604307 ***

Note You need to log in before you can comment on or make changes to this bug.