Bug 60649 - Replies to XDMCP query sent to wrong address, cause connection to fail
Replies to XDMCP query sent to wrong address, cause connection to fail
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
7.2
i686 Linux
low Severity high
: ---
: ---
Assigned To: Mike A. Harris
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-03-04 00:31 EST by Need Real Name
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-03-04 20:00:38 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2002-03-04 00:31:07 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 5.0; T312461)

Description of problem:
Replies to queries sent to wrong address

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Enable XDMCP on a RedHat machine (Standard steps: editing xdm-config, 
Xaccess, gdm.conf, kdmrc, etc) at address 192.168.1.10.
2.Install Cygwin/XFree86 under Windows 2000 at 192.168.1.1. 
3.These two machines are on the same subnet 192.168.1.x, sharing an Internet 
connection through a Windows 2000 Server at 192.168.1.100.
4.Launch XWin under Cygwin with the command "XWin -query 192.168.1.10 -from 
192.168.1.1
5. Use netstat -an to examine socket info on the RedHat 7.2 machine 
immediately. Notice that the RedHat 7.2 machine is sending UDP data to 
192.168.1.100, not 192.168.1.1 !!! 
	

Actual Results:  The XDMCP query fails. Although one can add route specifically 
on thr RedHat 7.2 machine to the machine that does the query and fix this 
problem, this just is not right.

Expected Results:  The RedHat 7.2 machine is supposed to send UDP data directly 
to the address of the machine that does the XDMCP query, not the gateway 
address !!!

Additional info:
Comment 1 Ngo Than 2002-03-04 07:19:41 EST
aasign to XFree86
Comment 2 Mike A. Harris 2002-03-04 20:00:34 EST
You might want to report this bug to XFree86.org also, so more eyes
are on it.
Comment 3 Mike A. Harris 2002-05-21 04:55:16 EDT
Just tested, and it works for me.  You must have some local configuration
issue.  Nobody else is reporting this problem.

Note You need to log in before you can comment on or make changes to this bug.