Bug 606526 - [abrt] crash in firefox-3.6.3-4.fc13: Process /usr/lib64/firefox-3.6/firefox was killed by signal 11 (SIGSEGV)
[abrt] crash in firefox-3.6.3-4.fc13: Process /usr/lib64/firefox-3.6/firefox ...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
13
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Gecko Maintainer
Fedora Extras Quality Assurance
abrt_hash:408fe2f02abb76cfcbd4c48e9a1...
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-21 16:49 EDT by Igor Katalnikov
Modified: 2010-08-31 12:08 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-31 12:08:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (105.88 KB, text/plain)
2010-06-21 16:49 EDT, Igor Katalnikov
no flags Details

  None (edit)
Description Igor Katalnikov 2010-06-21 16:49:53 EDT
abrt 1.1.1 detected a crash.

architecture: x86_64
Attached file: backtrace
cmdline: /usr/lib64/firefox-3.6/firefox
component: firefox
crash_function: nsProfileLock::FatalSignalHandler
executable: /usr/lib64/firefox-3.6/firefox
global_uuid: 408fe2f02abb76cfcbd4c48e9a1688445227e894
kernel: 2.6.33.5-124.fc13.x86_64
package: firefox-3.6.3-4.fc13
rating: 4
reason: Process /usr/lib64/firefox-3.6/firefox was killed by signal 11 (SIGSEGV)
release: Fedora release 13 (Goddard)

How to reproduce
-----
1. Maximized Print view window from live.nl
2.
3.
Comment 1 Igor Katalnikov 2010-06-21 16:49:56 EDT
Created attachment 425745 [details]
File: backtrace
Comment 2 Michal Schmidt 2010-06-22 08:21:02 EDT
Package: firefox-3.6.3-4.fc13
Architecture: x86_64
OS Release: Fedora release 13 (Goddard)


How to reproduce
-----
This is repeatable. I only have to use File -> Print Preview. Firefox seems to process the request for a couple of seconds, then dies.


Comment
-----
I tried different www pages, it crashed always.
Comment 3 Michal Schmidt 2010-06-24 03:16:56 EDT
At least in my case downgrading cups from 1.4.4 to 1.4.3 fixes it (yum downgrade cups cups-libs). Looks like a duplicate of 607159.

Igor, do you have cups 1.4.4 too?
Comment 4 Igor Katalnikov 2010-07-22 14:33:18 EDT
Cups 1.4.4-5 is the current version. Have not been printing anything for a while though. Using i386 driver for Canon i250 is lacking elegance. Decided to use it on i686 system which i should build shortly as file, sound and printer server. Printing to a pdf file seems to work.
Comment 5 d. johnson 2010-08-17 12:35:35 EDT
Thank you for taking the time to report this bug. Updates to this package have been released since it was first reported. If you have time to update the package and re-test, please do so and report the results here. You can obtain the updated package by typing 'yum update' or using the graphical updater, Software Update.


Disable extensions, plugins and non-default themes. Clear cookies and cache. Exit the browser completely.  Then restart the browser and attempt to replicate the crash.


#2  <signal handler called>
No symbol table info available.
#3  __pthread_mutex_lock (mutex=0x28) at pthread_mutex_lock.c:50
        type = <value optimized out>
        id = <value optimized out>
#4  0x00007f88e921634b in int_err_get (create=1) at err.c:354
        ret = 0x0
#5  0x00007f88e921609b in int_err_set_item (d=0x7f88e94eb1e0) at err.c:402
        p = <value optimized out>
        hash = <value optimized out>
#6  0x00007f88e9215a4c in err_load_strings (lib=0, str=0x7f88e94eb1e0)
    at err.c:676
No locals.
#7  0x00007f88e9216fb1 in ERR_load_ERR_strings () at err.c:662
No locals.
#8  0x00007f88e9217199 in ERR_load_crypto_strings () at err_all.c:113
No locals.
#9  0x0000003b7d239769 in SSL_load_error_strings () at ssl_err2.c:66




-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 6 Michal Schmidt 2010-08-23 07:23:24 EDT
I cannot reproduce the crash with current updates.
Comment 7 d. johnson 2010-08-31 12:08:35 EDT
Thank you!



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Note You need to log in before you can comment on or make changes to this bug.