Bug 60656 - Rescue disc has no support for SCSI tape drives
Rescue disc has no support for SCSI tape drives
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
:
Depends On:
Blocks: 79578
  Show dependency treegraph
 
Reported: 2002-03-04 05:34 EST by Need Real Name
Modified: 2007-04-18 12:40 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-02-27 22:05:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2002-03-04 05:34:56 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.78 [en] (X11; U; Linux 2.4.17 i586; Nav)

Description of problem:
The Rescue CD is missing the SCSI tape module, which makes restoring a system
from scratch take longer. Also magic "mknod" doesn't understand SCSI tape
devices.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Boot rescue CD
2. mknod /dev/st0
3. modprobe st

Actual Results:  The mknod fails since it has no knowledge of the st? devices.
The modprobe fails silently.

Expected Results:  mknod should create the device. modprobe should find the st
module and load it - it shouldn't fail silently. A simple "error loading"
message would be useful.

Additional info:
Comment 1 Mogens Kjaer 2002-07-03 09:56:28 EDT
The problem also exists in rh73.

You can create a new bootable disc1 that contains the
st.o module like this:

Install the anaconda and anaconda-runtime rpm's.

cd /usr/lib/anaconda-runtime

edit mk-images.i386

Look for SECSTAGE and change it into:

SECSTAGE="st agpgart raid0 raid1 raid5 $IDEMODS $SCSIMODS $LATEUSBMODS $FSMODS"

Edit mk-images

In the makeinitrd function, look for fd1 and add the two
lines:

$MBD_DIR st0 c 9 0 644 root:root
$MBD_DIR nst0 c 9 128 644 root:root

After the EOF line, add:

ln -s st0 $MBD_DIR/dev/tape
ln -s nst0 $MBD_DIR/dev/nrtape

This will create the necessary /dev entries for
the st.o module.

Follow the HOWTO

http://www.linuxworks.com.au/redhat-installer-howto.html

for creating new, bootable cd's

You only need to burn disc no. 1

Boot, "linux rescue", and when the prompt comes, write:

insmod st.o

to load the st.o module.
Comment 2 Jeremy Katz 2003-01-10 02:54:35 EST
This is added in CVS
Comment 3 Jay Turner 2003-01-23 12:25:25 EST
OK, with the re0122.nightly tree, here's what I'm seeing.  After normal boot, I
can modprobe the st driver and get feedback about it loading.  It's listed in
'lsmod' as well.  In rescue mode however, the devices exist, but running
'modprobe st' returns without any output.  The module is not listed in 'lsmod.'
 I have a machine sitting here at my desk if someone is interested.
Comment 4 Michael Fulbright 2003-01-28 19:37:32 EST
I believe this is working - try modprobe st.o.

Also you need to do this on a machine with a scsi tape - the loading of the st.o
module should be automatic in this case when entering rescue mode.
Comment 5 Jay Turner 2003-02-27 22:05:58 EST
Fix confirmed with the latest code.

Note You need to log in before you can comment on or make changes to this bug.