This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 606585 - bg.conf file not found
bg.conf file not found
Status: CLOSED DUPLICATE of bug 606478
Product: Fedora
Classification: Fedora
Component: bind (Show other bugs)
12
All Linux
low Severity medium
: ---
: ---
Assigned To: Adam Tkac
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-21 22:24 EDT by Nivag
Modified: 2013-04-30 19:46 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-23 12:49:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Nivag 2010-06-21 22:24:31 EDT
Description of problem:
named fails to start after recent yum update

Version-Release number of selected component (if applicable):


How reproducible:
Everytime

Steps to Reproduce:
1. ping slashdot.org
2.
3.
  
Actual results:
host not known

Expected results:
ping should work

Additional info:

from /var./log/messages:
Jun 22 09:48:12 saturn named: /etc/pki/dnssec-keys//named.dnssec.keys:1: open: /etc/pki/dnssec-keys//production/bg.conf: file not found 

# cd /etc/pki/dnssec-keys 
# ll
total 4 
-rw-r--r-- 1 root root 422 2010-02-13 18:02 named.dnssec.keys 
# cat named.dnssec.keys 
include "/etc/pki/dnssec-keys//production/bg.conf"; 
include "/etc/pki/dnssec-keys//production/br.conf"; 
include "/etc/pki/dnssec-keys//production/cz.conf"; 
include "/etc/pki/dnssec-keys//production/gov.conf"; 
include "/etc/pki/dnssec-keys//production/museum.conf"; 
include "/etc/pki/dnssec-keys//production/org.conf"; 
include "/etc/pki/dnssec-keys//production/pr.conf"; 
include "/etc/pki/dnssec-keys//production/se.conf"; 

yum log for last update:
Jun 22 07:54:30 Updated: 1:java-1.6.0-openjdk-1.6.0.0-39.b18.fc12.x86_64
Jun 22 07:54:31 Updated: nss-softokn-freebl-3.12.6-2.fc12.1.x86_64
Jun 22 07:54:32 Updated: nss-softokn-3.12.6-2.fc12.1.x86_64
Jun 22 07:54:36 Installed: ldns-1.6.4-1.fc12.x86_64
Jun 22 07:54:37 Installed: unbound-libs-1.4.4-2.fc12.x86_64
Jun 22 07:54:38 Updated: libssh-0.4.4-1.fc12.x86_64
Jun 22 07:54:40 Installed: unbound-1.4.4-2.fc12.x86_64
Jun 22 07:54:41 Updated: 1:java-1.6.0-openjdk-plugin-1.6.0.0-39.b18.fc12.x86_64
Jun 22 07:54:47 Updated: 1:java-1.6.0-openjdk-devel-1.6.0.0-39.b18.fc12.x86_64
Jun 22 07:54:48 Updated: sudo-1.7.2p6-2.fc12.x86_64
Jun 22 07:54:50 Updated: sendmail-8.14.4-3.fc12.x86_64
Jun 22 07:54:51 Updated: nss-softokn-devel-3.12.6-2.fc12.1.x86_64
Jun 22 07:54:52 Updated: hunspell-en-0.20100322-1.fc12.noarch
Jun 22 07:55:17 Updated: 1:java-1.6.0-openjdk-debuginfo-1.6.0.0-39.b18.fc12.x86_64
Jun 22 07:55:18 Updated: nss-softokn-debuginfo-3.12.6-2.fc12.1.x86_64
Jun 22 07:55:50 Updated: 1:java-1.6.0-openjdk-javadoc-1.6.0.0-39.b18.fc12.x86_64
Jun 22 07:55:55 Updated: nss-debuginfo-3.12.6-7.fc12.x86_64
Jun 22 07:55:56 Updated: nss-softokn-freebl-3.12.6-2.fc12.1.i686
Jun 22 07:55:57 Updated: nss-3.12.6-7.fc12.x86_64
Jun 22 07:55:58 Updated: nss-sysinit-3.12.6-7.fc12.x86_64
Jun 22 07:55:59 Updated: nss-devel-3.12.6-7.fc12.x86_64
Jun 22 07:55:59 Updated: nss-tools-3.12.6-7.fc12.x86_64
Jun 22 07:56:32 Erased: dnssec-conf


# ll /etc/named.conf
-rw-r----- 1 root named 1113 2010-05-04 13:04 /etc/named.conf
# 

>>> The /etc/named.conf had not been recently changed! <<<

# cat /etc/named.conf 
//
// named.conf
//
// Provided by Red Hat bind package to configure the ISC BIND named(8) DNS
// server as a caching only nameserver (as a localhost DNS resolver only).
//
// See /usr/share/doc/bind*/sample/ for example named configuration files.
//

options {
	listen-on port 53 { 127.0.0.1; 192.168.1.204; };
	listen-on-v6 port 53 { ::1; };
	directory 	"/var/named";
	dump-file 	"/var/named/data/cache_dump.db";
        statistics-file "/var/named/data/named_stats.txt";
        memstatistics-file "/var/named/data/named_mem_stats.txt";
	allow-query     { localhost; 192.168.1.0/24; };
	forwarders port 53 { 202.27.158.40; 202.27.156.72; };
	recursion yes;
	dnssec-enable no;
	dnssec-validation no;
	// dnssec-lookaside . trust-anchor dlv.isc.org.;
};

logging {
        channel default_debug {
                file "data/named.run";
                severity dynamic;
        };
};

zone "." IN {
	type hint;
	file "named.ca";
};

include "/etc/named.rfc1912.zones";
include "/etc/named.rfc1918.zones";


include "/etc/pki/dnssec-keys//named.dnssec.keys";
include "/etc/pki/dnssec-keys//dlv/dlv.isc.org.conf";
#
Comment 1 Nivag 2010-06-21 23:51:41 EDT
I fixed the problem by:

(1) deleting all the /etc/named* files
(2) yum remove bind*
(3) yum install bind*
(4) appling minimal changes to to the fresh /etc/named.conf

# diff named.conf named.conf-20100622a
11c11
< 	listen-on port 53 { 127.0.0.1; 192.168.1.204; };
---
> 	listen-on port 53 { 127.0.0.1; };
17c17
< 	allow-query     { localhost; 192.168.1.0/24; };
---
> 	allow-query     { localhost; };
19d18
< 	forwarders port 53 { 202.27.158.40; 202.27.156.72; };
#
Comment 2 Jordan Russell 2010-06-22 13:27:40 EDT
Looks like the same issue I'm seeing: bug 606478
The error is caused by the removal of the dnssec-conf package.

My workaround for now:
- forcefully uninstall unbound ("rpm -e --nodeps unbound unbound-libs")
- manually download the last dnssec-conf package ("yumdownloader dnssec-conf")
- manually install the dnssec-conf package ("rpm -ivh dnssec-conf*.rpm")


Would someone involved with bind/unbound/dnssec-conf please take a look at this, or notify the responsible party?
This is a pretty serious regression, considering the "/etc/pki/dnssec-keys" references are present in named.conf *by default* (or at least were at one time).
Comment 3 Nivag 2010-06-22 16:42:42 EDT
Hmm... My system had been up for a few days, so it is likely to be that the unbound got me as well.

# grep unbound /var/log/yum.log
/var/log/yum.log:Jun 22 07:54:37 Installed: unbound-libs-1.4.4-2.fc12.x86_64
/var/log/yum.log:Jun 22 07:54:40 Installed: unbound-1.4.4-2.fc12.x86_64
Comment 4 Adam Tkac 2010-06-23 12:49:49 EDT

*** This bug has been marked as a duplicate of bug 606478 ***

Note You need to log in before you can comment on or make changes to this bug.