Bug 606700 - Anaconda graphical installation exited abnormally
Summary: Anaconda graphical installation exited abnormally
Keywords:
Status: CLOSED DUPLICATE of bug 607650
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: anaconda
Version: 6.0
Hardware: All
OS: Linux
high
high
Target Milestone: rc
: ---
Assignee: Anaconda Maintenance Team
QA Contact: Release Test Team
URL:
Whiteboard:
Depends On: 605289
Blocks: 519838
TreeView+ depends on / blocked
 
Reported: 2010-06-22 09:15 UTC by Eduard Benes
Modified: 2010-06-30 15:26 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-06-30 15:26:29 UTC


Attachments (Terms of Use)
anaconda logs (39.40 KB, application/x-gzip)
2010-06-22 09:15 UTC, Eduard Benes
no flags Details
screenshot (4.64 KB, image/png)
2010-06-22 14:04 UTC, Eduard Benes
no flags Details
tty3 (19.28 KB, image/png)
2010-06-22 14:44 UTC, Miroslav Vadkerti
no flags Details
tty4 (16.13 KB, image/png)
2010-06-22 14:44 UTC, Miroslav Vadkerti
no flags Details

Description Eduard Benes 2010-06-22 09:15:21 UTC
Created attachment 425873 [details]
anaconda logs

Description of problem:
Anakonda in compose rel-eng/RHEL6.0-20100621.0 exits abnormally if one deselects all repositories, hits warning for missing repositories and than enables the default one (Red Hat Enterprise Linux). 

Version-Release number of selected component (if applicable):
anaconda-13.21.50-9 

How reproducible:
always

Steps to Reproduce:
1. start graphical installation of tree RHEL6.0-20100621.0 (using anaconda-13.21.50-9)
2. go over individual screens with default setting up to screen with install (spin) selection and additional repositories
3. Select "Minimal" install radio button or leave default option "Basic Server"
4. Uncheck "Red Hat Enterprise Linux" checkbox in additinal repositories (all are unchecked now)
5. Click Next
6. Warning message "No Software Repos Enabled" shows up, click OK
7. Check "Red Hat Enterprise Linux" checkbox in additional repositories (only this one is checked now)
8. Click Next
9. install exits abnormally

Actual results:
install exits abnormally

Expected results:
installation should continue successfully 

Additional info:
Selecting "Minimal" install radio button and not touching the additional repositories works as expected. All logs are in the attachment.

Comment 2 Chris Lumens 2010-06-22 13:52:00 UTC
I don't see anything in your logs that explains what the actual error message is.  Are you getting a traceback?  If so, is there a /tmp/anaconda-tb-* file?  I don't see one in the tarball.  If it's not a traceback, can you at least attach a screenshot of what's on tty1?

Comment 3 Eduard Benes 2010-06-22 14:04:47 UTC
Created attachment 425935 [details]
screenshot

Comment 4 Chris Lumens 2010-06-22 14:13:30 UTC
That wasn't as helpful as I hoped it would be.  Can you please also attach a screenshot of tty4?  That's the kernel log; I'm hoping there's a message not making it into /tmp/syslog that'll explain what's going on.

Comment 5 Miroslav Vadkerti 2010-06-22 14:43:52 UTC
Attaching 2 screenshots from other 2 ttys. No /tmp/anaconda-tb-* (no traceback). Also note this only happens when minimal option selected. With basic server option it workerd fine.

Comment 6 Miroslav Vadkerti 2010-06-22 14:44:11 UTC
Created attachment 425957 [details]
tty3

Comment 7 Miroslav Vadkerti 2010-06-22 14:44:31 UTC
Created attachment 425958 [details]
tty4

Comment 8 Miroslav Vadkerti 2010-06-22 14:44:52 UTC
Anything else I can help with?

Comment 9 Chris Lumens 2010-06-22 16:04:12 UTC
I am unable to reproduce this problem with the latest tree, doing a DVD install, and following both sets of instructions given above.  Can anyone think of any additional information that might help debug this?

Comment 10 Miroslav Vadkerti 2010-06-22 16:10:19 UTC
We were using network installation when reproducing this. Can you please try network installation on RHEL6.0-20100621.0?

Comment 12 Bill Nottingham 2010-06-22 16:35:25 UTC
I tried these steps with network virt installation on 20100621.0... it worked OK.

Comment 13 Chris Lumens 2010-06-22 18:13:31 UTC
Likewise.  Is this being tested on specific hardware that always fails?  Can you try other setups and see if you get the same result?

Comment 16 Bill Nottingham 2010-06-22 18:59:08 UTC
Even selecting minimal works for me.

Comment 18 David Cantrell 2010-06-22 20:28:35 UTC
Three other people have failed to reproduce this bug, closing.

Comment 19 Karel Srot 2010-06-30 14:20:53 UTC
Reopening this bug. Could you please give it another try?
I am facing this problem while installing RHEL6.0-20100622.1.

Network install:  http://download.devel.redhat.com/rel-eng/RHEL6.0-20100622.1/6/Server/x86_64/os/
x86_64 platform - I did not have this problem with 32bit
quest system: 8GB qcow2 hdd image, "uses all space" layout


Minimal install,
additional repos Red Hat Enterprise Linux (checked by default)
customize Now (customize packages)
  add Base System/Base  
  add Desktops/Desktop
      Desktops/Fonts
      Desktops/X Window System
  add Development/Development Tools

Anaconda crashes directly (around 40% cases)
or
Anaconda GUI "freezes" during Dependency check - 95% cpu load, does not move forward even after 1 hour (around 40% cases)

I tried to install this compose in kvm-qemu something like ten times and I have never succeeded. 
Anaconda did freeze in various parts of the installation process.

Comment 21 Hans de Goede 2010-06-30 15:26:29 UTC
Given that:
-all reports are of trees with a date of RHEL6.0-20100621.0 or later
-all reports only happen inside kvm
-all reports indicate random crashes during the package transaction

This seems to be the very same memory corruption bug under kvm which is being tracked in bug 607650, marking this one as a dupicate.

*** This bug has been marked as a duplicate of bug 607650 ***


Note You need to log in before you can comment on or make changes to this bug.