Bug 60672 - Files time in future
Files time in future
Status: CLOSED DUPLICATE of bug 6175
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
8.0
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Jeremy Katz
Brock Organ
:
: 60428 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-03-04 12:10 EST by David Balažic
Modified: 2007-04-18 12:40 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:48:32 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Balažic 2002-03-04 12:10:07 EST
After installing rhl 7.2.90 and booting it,
some system files have time in future. There is a symptom
right at boot :

Starting lpd: No Printers Defined                          [  OK  ]
Starting sendmail: make: *** Warning: File `virtusertable.db' has modification 
time in the future
(2002-02-20 23:37:17 > 2002-02-20 22:57:32)
make: warning:  Clock skew detected.  Your build may be incomplete.
                                                           [  OK  ]
Comment 1 Michael Fulbright 2002-03-04 15:29:14 EST
Is this for Hampton Beta 1?
Comment 2 Jeremy Katz 2002-03-04 15:37:00 EST
This is happening because we don't set the timezone during the installer (dupe
of another bug assigned to msw iirc)
Comment 3 David Balažic 2002-03-05 03:29:47 EST
Yes, this is for Hampton Beta 1 ( and all previous RHL versions, for that 
matter ).

As I see it, this is what happens :

-installer CD boots.
-CMOS clock is read and interpreted as if it were in UTC.
-files are installed
-the new installation is booted
-time from the CMOS clock is read, this time correctly

So if UTC time is 10:00 and my timezone is GMT-1 ( Europe/Ljubljana ), so my 
localtime is 11:00, which is also in the CMOS clock, then the installer sets 
the system time to 11:00 UTC, which is wrong and in the future, while the 
installed system , when booted after installation,when CMOS is 11:20 ( assume 
installation took 20 minutes ) , correctly sets the system time to 10:20 UTC ( 
and then complains that some files have time set to 11:00 UTC )

Recommended fix :
after the user selects his timezime and is_CMOS_UTC settings,
run hwclock again, with the correct parameters and environment.
Comment 4 Jeremy Katz 2002-03-13 17:29:59 EST
*** Bug 60428 has been marked as a duplicate of this bug. ***
Comment 5 David Balažic 2002-03-23 09:41:55 EST
No surprise: the bug is still present in Hampton beta2
Comment 6 Michael Fulbright 2002-03-26 12:31:07 EST
Deferring to future release.
Comment 7 David Balažic 2002-11-19 15:59:33 EST
Bug properly "deffered" to RHL 8.0.
( bug still present )
Comment 8 Jeremy Katz 2002-12-13 17:59:47 EST

*** This bug has been marked as a duplicate of 6175 ***
Comment 9 Red Hat Bugzilla 2006-02-21 13:48:32 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.