Bug 606789 - [abrt] firefox-3.6.3-4.fc14: Process /usr/lib/firefox-3.6/firefox was killed by signal 11 (SIGSEGV)
[abrt] firefox-3.6.3-4.fc14: Process /usr/lib/firefox-3.6/firefox was killed ...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
14
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Gecko Maintainer
Fedora Extras Quality Assurance
abrt_hash:1bfb5ccb2247d846fcf26262be6...
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-22 10:00 EDT by Kjartan Maraas
Modified: 2010-08-18 01:39 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-18 01:39:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (45.76 KB, text/plain)
2010-06-22 10:00 EDT, Kjartan Maraas
no flags Details

  None (edit)
Description Kjartan Maraas 2010-06-22 10:00:42 EDT
abrt version: 1.1.5
architecture: i686
Attached file: backtrace
cmdline: /usr/lib/firefox-3.6/firefox -UILocale nb-NO
comment: Just started Firefox and it crashed. 
component: firefox
crash_function: nsProfileLock::FatalSignalHandler
executable: /usr/lib/firefox-3.6/firefox
global_uuid: 1bfb5ccb2247d846fcf26262be6465fa2fd8f385
kernel: 2.6.33.5-124.fc13.i686.PAE
package: firefox-3.6.3-4.fc14
rating: 4
reason: Process /usr/lib/firefox-3.6/firefox was killed by signal 11 (SIGSEGV)
release: Fedora release 14 (Rawhide)
time: 1277214897
uid: 500

How to reproduce
-----
1.Happens on startup
2.
3.
Comment 1 Kjartan Maraas 2010-06-22 10:00:44 EDT
Created attachment 425929 [details]
File: backtrace
Comment 2 Kjartan Maraas 2010-06-23 08:07:22 EDT
turning off enforcing mode in selinux fixed this for me. I see this in the logs:

Jun 23 14:04:41 e4300 kernel: type=1400 audit(1277294681.731:13): avc:  denied  { execmem } for  pid=5814 comm="firefox" scontext=unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1023 tcontext=unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1023 tclass=process
Comment 3 Bug Zapper 2010-07-30 08:11:33 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 14 development cycle.
Changing version to '14'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 4 d. johnson 2010-08-17 13:03:09 EDT
Thank you for taking the time to report this bug. Updates to this package have been released since it was first reported. If you have time to update the package and re-test, please do so and report the results here. You can obtain the updated package by typing 'yum update' or using the graphical updater, Software Update.


Disable extensions, plugins and non-default themes. Clear cookies and cache. Exit the browser completely.  Then restart the browser and attempt to replicate the crash.


For selinux, verify that your files are labeled properly with su -c 'fixfiles check'  -- This command takes 2-3 minutes to complete.  You can run 'restorecon' to restore the context labels.
#3  <signal handler called>
No symbol table info available.
#4  0x003621b9 in addMem (this=0xb76ebb60, start=@0xb761088c, end=@0xb7610890)
    at nanojit/CodeAlloc.cpp:327
        b = 0xffffffff
#5  nanojit::CodeAlloc::alloc (this=0xb76ebb60, start=@0xb761088c, end=
    @0xb7610890) at nanojit/CodeAlloc.cpp:132
        mem = <value optimized out>
        b = 0xffffffff
#6  0x003581da in nanojit::Assembler::codeAlloc (this=0xb7610844, start=
    @0xb761088c, end=@0xb7610890, eip=@0xb761089c)
    at nanojit/Assembler.cpp:192
No locals.
#7  0x00367945 in nanojit::Assembler::nativePageSetup (this=0xb7610844)
    at nanojit/Nativei386.cpp:1732
No locals.
#8  0x00359645 in nanojit::Assembler::beginAssembly (this=0xb7610844, frag=
    0xb7610f14) at nanojit/Assembler.cpp:658
No locals.
#9  0x0036375f in nanojit::compile (assm=0xb7610844, frag=0xb7610f14)
    at nanojit/LIR.cpp:1954
No locals.
#10 0x0033cbfe in TraceRecorder::compile (this=0xb76b2bc0, tm=0xb716e068)




-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 5 Kjartan Maraas 2010-08-17 16:41:38 EDT
I can confirm that this was fixed by an updated selinux-policy package.
Comment 6 d. johnson 2010-08-18 01:39:26 EDT
Thank you!

Note You need to log in before you can comment on or make changes to this bug.