Bug 606879 - Can not disable Alt-shift (next-Input-method) hotkey
Can not disable Alt-shift (next-Input-method) hotkey
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: ibus (Show other bugs)
13
All Linux
medium Severity high
: ---
: ---
Assigned To: fujiwara
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-22 12:27 EDT by Kai.Fan
Modified: 2010-07-06 13:31 EDT (History)
5 users (show)

See Also:
Fixed In Version: ibus-1.3.5-4.fc13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-06 13:31:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Kai.Fan 2010-06-22 12:27:55 EDT
Description of problem:

I can't disable the Alt-Shift hotkey even if I clean it up in the IM preference page.

Version-Release number of selected component (if applicable):

[fktpp@fklaptop ~]$ rpm -qa | grep ibus
ibus-1.3.5-2.fc13.x86_64
ibus-anthy-1.2.1-1.fc13.x86_64
libuser-python-0.56.16-1.fc13.x86_64
ibus-hangul-1.3.0.20100329-1.fc13.x86_64
libuser-0.56.16-1.fc13.x86_64
ibus-m17n-1.3.0-1.fc13.x86_64
ibus-gtk-1.3.5-2.fc13.x86_64
ibus-rawcode-1.3.0.20100421-1.fc13.x86_64
libuser-devel-0.56.16-1.fc13.x86_64
ibus-chewing-1.3.4.20100605-1.fc13.x86_64
ibus-pinyin-1.3.8-1.fc13.x86_64
ibus-libs-1.3.5-2.fc13.x86_64
libusb-0.1.12-22.fc12.x86_64
ibus-pinyin-db-open-phrase-1.3.8-1.fc13.noarch
libusb1-1.0.6-2.fc13.x86_64


How reproducible:

Steps to Reproduce:
1. in chinese local LANG=zh_CN.utf8
2. clean all but "Ctrl-Space" hotkeys in ibus preferences settting.
3. Press "Alt-Shift" in gedit editing area
  
Actual results:
ibus pinyin activated

Expected results:
ibus pinyin should only be activated by "Ctrl-Space"

Additional info:
Comment 1 Jens Petersen 2010-06-23 08:02:17 EDT
Thanks for the report I have seen this too.
Comment 2 Peng Huang 2010-06-23 23:13:53 EDT
Fixed in upstream. And I will build it for fedora soon.
Comment 3 fujiwara 2010-06-30 01:28:14 EDT
Copied the changes on HEAD.
http://koji.fedoraproject.org/koji/taskinfo?taskID=2282208
Comment 4 Jens Petersen 2010-06-30 05:38:50 EDT
Thanks - I tested but looks like it is not fixed yet upstream in trunk.

http://github.com/phuang/ibus/commit/817399605bdeeb83fa4729018b2b17ad7870576d
Comment 5 fujiwara 2010-07-01 06:10:43 EDT
After we talked off line, we almost agreed with the current patch.

(In reply to comment #0)
> Description of problem:
> 
> I can't disable the Alt-Shift hotkey even if I clean it up in the IM preference
> page.
> 

Could you test the fixed rpm?
http://koji.fedoraproject.org/koji/taskinfo?taskID=2285547
Comment 6 Fedora Update System 2010-07-01 06:14:45 EDT
ibus-1.3.5-4.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/ibus-1.3.5-4.fc13
Comment 7 Fedora Update System 2010-07-01 14:43:20 EDT
ibus-1.3.5-4.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update ibus'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/ibus-1.3.5-4.fc13
Comment 8 Fedora Update System 2010-07-06 13:31:21 EDT
ibus-1.3.5-4.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.