Bug 60689 - /etc/init.d/halt doesn't take standard init-script arguments
/etc/init.d/halt doesn't take standard init-script arguments
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: initscripts (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-03-04 16:04 EST by Rich Lafferty
Modified: 2014-03-16 22:25 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-03-04 16:04:35 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rich Lafferty 2002-03-04 16:04:31 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.8) Gecko/20020205

Description of problem:
The /etc/init.d/halt script doesn't follow the init.d standard of 
start-stop-status. While "start" and "stop" admittedly aren't useful for
halt, it means an unpleasant surprise when you start with the 
impression that calling an init script with the "status" argument
doesn't change system or service state.

Since halt is called as rc0.d/S10halt, halt should run on "halt 
start", with "halt stop" and "halt status" being noops.

Version-Release number of selected component (if applicable):
initscripts-5.49-1

How reproducible:
Always

Steps to Reproduce:
Simple: /etc/init.d/halt status

Real-world example that bit me, after noticing some services didn't
start after reboot when I expected them to:

for i in /etc/init.d/*; do $i status; done

	

Actual Results:  System halted.

Expected Results:  Something nondestructive; perhaps a status report, perhaps an
error message, perhaps a noop.

Additional info:

The same problem exists in /etc/init.d/killall and /etc/init.d/single.
Comment 1 Rich Lafferty 2002-03-04 16:30:17 EST
Checked a 7.2-ish system, and this has been resolved at some point after
initscripts-5.49-1 and now. Nevermind. :-)

Note You need to log in before you can comment on or make changes to this bug.