Bug 607107 - crash at a start (vmware_drv.so)
crash at a start (vmware_drv.so)
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-vmware (Show other bugs)
14
All Linux
low Severity high
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-23 05:14 EDT by Ales Kozumplik
Modified: 2018-04-11 08:23 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-16 12:57:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
X.log (27.86 KB, text/plain)
2010-06-23 05:14 EDT, Ales Kozumplik
no flags Details

  None (edit)
Description Ales Kozumplik 2010-06-23 05:14:50 EDT
Created attachment 426205 [details]
X.log

Description of problem:

since about two days ago the rawhide anaconda composes have X crashing on vmware. vnc install works fine.

X.log attached.
Comment 1 Ales Kozumplik 2010-06-23 05:22:56 EDT
Tried an i386 compose in x86_64 kvm (the only other compose vs architecture I have available) and X starts allright.
Comment 2 Matěj Cepl 2010-06-23 08:17:37 EDT
(In reply to comment #1)
> Tried an i386 compose in x86_64 kvm (the only other compose vs architecture I
> have available) and X starts allright.    

Backtrace:
[    47.394] 0: Xorg (xorg_backtrace+0x3c) [0x80e51bc]
[    47.394] 1: Xorg (0x8048000+0x5d166) [0x80a5166]
[    47.394] 2: (vdso) (__kernel_rt_sigreturn+0x0) [0xda640c]
[    47.395] 3: /usr/lib/xorg/modules/drivers/vmware_drv.so (0x516000+0x65fb) [0x51c5fb]
[    47.395] 4: Xorg (0x8048000+0xd3a27) [0x811ba27]
[    47.395] 5: Xorg (CompositePicture+0x290) [0x810ea50]
[    47.395] 6: Xorg (miTrapezoids+0x247) [0x81b8d07]
[    47.395] 7: Xorg (CompositeTrapezoids+0xa0) [0x810e720]
[    47.395] 8: Xorg (0x8048000+0xcf533) [0x8117533]
[    47.395] 9: Xorg (0x8048000+0xc9804) [0x8111804]
[    47.395] 10: Xorg (0x8048000+0x25f37) [0x806df37]
[    47.396] 11: Xorg (0x8048000+0x1a675) [0x8062675]
[    47.396] 12: /lib/libc.so.6 (__libc_start_main+0xe6) [0x126d06]
[    47.396] 13: Xorg (0x8048000+0x1a261) [0x8062261]
[    47.397] Segmentation fault at address 0x8
[    47.397] 
Fatal server error:
[    47.397] Caught signal 11 (Segmentation fault). Server aborting
[    47.397] 

Well, your test in kvm just provides more evidence that this is vmware_drv issue (kvm uses cirrus video card emulation).
Comment 3 Bug Zapper 2010-07-30 08:12:25 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 14 development cycle.
Changing version to '14'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 4 Fedora End Of Life 2012-08-16 12:57:04 EDT
This message is a notice that Fedora 14 is now at end of life. Fedora 
has stopped maintaining and issuing updates for Fedora 14. It is 
Fedora's policy to close all bug reports from releases that are no 
longer maintained.  At this time, all open bugs with a Fedora 'version'
of '14' have been closed as WONTFIX.

(Please note: Our normal process is to give advanced warning of this 
occurring, but we forgot to do that. A thousand apologies.)

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, feel free to reopen 
this bug and simply change the 'version' to a later Fedora version.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we were unable to fix it before Fedora 14 reached end of life. If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora, you are encouraged to click on 
"Clone This Bug" (top right of this page) and open it against that 
version of Fedora.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Note You need to log in before you can comment on or make changes to this bug.