Bug 607137 - window2003 and window2008 get incorrect mem
window2003 and window2008 get incorrect mem
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: qemu-kvm (Show other bugs)
6.0
All Linux
low Severity medium
: rc
: ---
Assigned To: Virtualization Maintenance
Virtualization Bugs
:
Depends On:
Blocks: 580953
  Show dependency treegraph
 
Reported: 2010-06-23 07:00 EDT by Suqin Huang
Modified: 2010-11-22 04:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-22 04:11:31 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Suqin Huang 2010-06-23 07:00:42 EDT
Description of problem:
boot win2003 and win2008 with 2048M mem, guest only get 2047M, if boot with 4096M, will get 4095M

Version-Release number of selected component (if applicable):
qemu-kvm-0.12.1.2-2.78.el6.x86_64

How reproducible:
100%

Steps to Reproduce:
1. boot guest

qemu-kvm -name 'vm1' -monitor tcp:0:6001,server,nowait -drive file=/win2003-64.qcow2,if=ide,cache=none,werror=stop,boot=on \
-net nic,vlan=0,model=rtl8139,macaddr=02:7E:61:38:f9:40 \
-net tap,vlan=0,script=/qemu-ifup-switch,downscript=no \
-m 4096 -smp 2 -soundhw ac97 -redir tcp:5000::22 -vnc :0 -usbdevice tablet -rtc-td-hack -cpu qemu64,+sse2 -no-kvm-pit-reinjection 



2. get meminfo
 systeminfo | find "Total Physical Memory"

3.
  
Actual results:
Memory size mismatch:
06:04:20 ERROR|     Assigned to VM: 4096
06:04:20 ERROR|     Reported by OS: 4095


Expected results:


Additional info:
xp, 08r2, win7 can get correct mem.
Comment 2 RHEL Product and Program Management 2010-06-23 07:32:56 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 3 RHEL Product and Program Management 2010-07-15 10:17:32 EDT
This issue has been proposed when we are only considering blocker
issues in the current Red Hat Enterprise Linux release. It has
been denied for the current Red Hat Enterprise Linux release.

** If you would still like this issue considered for the current
release, ask your support representative to file as a blocker on
your behalf. Otherwise ask that it be considered for the next
Red Hat Enterprise Linux release. **
Comment 5 Amit Shah 2010-11-10 06:30:37 EST
This looks like an issue with the guest OS.  Where do the ERROR lines you quoted come from?  Does this behaviour result in any loss of functionality or other bug in the guest operation?
Comment 6 Suqin Huang 2010-11-22 02:52:25 EST
run it with autotest script, get it from the test result.
the same result when issue: systeminfo | find "Total Physical Memory" cmd in guest.

doesn't result in loss  of functionality or other bug in the guest operation.
Comment 7 Amit Shah 2010-11-22 04:11:31 EST
In that case I'm fairly certain it's a bug in the guest and we can close this bug.

Note You need to log in before you can comment on or make changes to this bug.