Bug 607144 - mock -r epel-5-x86_64 --rebuild X.src.rpm is not working (dependencies problems?)
Summary: mock -r epel-5-x86_64 --rebuild X.src.rpm is not working (dependencies proble...
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: mock   
(Show other bugs)
Version: 13
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Clark Williams
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-06-23 11:19 UTC by Catalin BOIE
Modified: 2013-01-10 06:02 UTC (History)
4 users (show)

Fixed In Version: mock-1.1.10-1.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-07 23:24:14 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Catalin BOIE 2010-06-23 11:19:41 UTC
Description of problem:
Cannot use mock with target epel-5-x86_64.

Version-Release number of selected component (if applicable):
mock-1.1.1-1.fc13.noarch

How reproducible:
mock -r epel-5-x86_64 --rebuild Conn-1.0.31-1.src.rpm

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:
Shoult compile the src rpm just fine.

Additional info:

mock -r epel-5-x86_64 --rebuild Conn-1.0.31-1.src.rpm 
INFO: mock.py version 1.1.1 starting...
State Changed: init plugins
State Changed: start
INFO: Start(Conn-1.0.31-1.src.rpm)  Config(epel-5-x86_64)
State Changed: lock buildroot
State Changed: clean
State Changed: init
State Changed: lock buildroot
Mock Version: 1.1.1
INFO: Mock Version: 1.1.1
INFO: enabled root cache
INFO: enabled yum cache
State Changed: cleaning yum metadata
INFO: enabled ccache
State Changed: running yum
ERROR: Exception(Conn-1.0.31-1.src.rpm) Config(epel-5-x86_64) 1 minutes 3 seconds
INFO: Results and/or logs in: /var/lib/mock/epel-5-x86_64/result
ERROR: Command failed: 
 # /usr/bin/yum --installroot /var/lib/mock/epel-5-x86_64/root/  install buildsys-build
Error: Package: buildsys-build-0.7-2.el5.noarch (groups)
           Requires: perl
Error: Package: buildsys-build-0.7-2.el5.noarch (groups)
           Requires: rpm-build
Error: Package: buildsys-build-0.7-2.el5.noarch (groups)
           Requires: bash
Error: Package: buildsys-build-0.7-2.el5.noarch (groups)
           Requires: gcc
Error: Package: buildsys-build-0.7-2.el5.noarch (groups)
           Requires: redhat-release
Error: Package: redhat-rpm-config-8.0.45-32.el5.centos.noarch (core)
           Requires: perl(Getopt::Long)
Error: Package: redhat-rpm-config-8.0.45-32.el5.centos.noarch (core)
           Requires: /bin/bash
Error: Package: buildsys-build-0.7-2.el5.noarch (groups)
           Requires: coreutils
Error: Package: redhat-rpm-config-8.0.45-32.el5.centos.noarch (core)
           Requires: /usr/bin/perl
 You could try using --skip-broken to work around the problem
Error: Package: buildsys-build-0.7-2.el5.noarch (groups)
           Requires: tar
Error: Package: buildsys-build-0.7-2.el5.noarch (groups)
           Requires: diffutils
Error: Package: buildsys-build-0.7-2.el5.noarch (groups)
           Requires: cpio
Error: Package: buildsys-build-0.7-2.el5.noarch (groups)
           Requires: gzip
Error: Package: buildsys-build-0.7-2.el5.noarch (groups)
           Requires: make
Error: Package: buildsys-build-0.7-2.el5.noarch (groups)
           Requires: sed
Error: Package: buildsys-build-0.7-2.el5.noarch (groups)
           Requires: which
Error: Package: redhat-rpm-config-8.0.45-32.el5.centos.noarch (core)
           Requires: /bin/sh
Error: Package: buildsys-build-0.7-2.el5.noarch (groups)
           Requires: elfutils
Error: Package: buildsys-build-0.7-2.el5.noarch (groups)
           Requires: bzip2
Error: Package: buildsys-build-0.7-2.el5.noarch (groups)
           Requires: gcc-c++
Error: Package: buildsys-build-0.7-2.el5.noarch (groups)
           Requires: unzip
Error: Package: buildsys-build-0.7-2.el5.noarch (groups)
           Requires: patch
 You could try running: rpm -Va --nofiles --nodigest

Comment 1 Jan Kratochvil 2010-07-02 13:44:15 UTC
There are usually some rpm database format problems across host vs. guest OS,
you may want to try:
rpm -r /var/lib/mock/epel-5-x86_64/root -q gcc
You may want to do:
rm -f /var/lib/mock/epel-5-x86_64/root/var/lib/rpm/__db.*
rpm -r /var/lib/mock/epel-5-x86_64/root --rebuilddb

Comment 2 Catalin BOIE 2010-07-02 14:23:51 UTC
Maybe is because I try to build 64bit on 32bit machine? Shouldn't it error out earlier?
Also, because of the chroot, shouldn't it behave correctly.
IMHO should work out-of-the-box.

Comment 3 Clark Williams 2010-07-09 20:57:19 UTC
I don't believe that building 64-bit packages from a 32-bit system has ever been supported on Fedora or RHEL. 

I'll look at detecting this and error'ing out early.

Comment 4 Catalin BOIE 2010-07-12 05:43:04 UTC
Thanks!

Comment 5 Clark Williams 2010-07-27 18:50:17 UTC
Added code to the upcoming 1.1.2 mock release to catch invalid architecture combinations.

Comment 6 Fedora Update System 2010-08-03 22:24:46 UTC
mock-1.1.3-1.fc14 has been submitted as an update for Fedora 14.
http://admin.fedoraproject.org/updates/mock-1.1.3-1.fc14

Comment 7 Fedora Update System 2010-08-03 22:25:39 UTC
mock-1.1.3-1.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/mock-1.1.3-1.fc13

Comment 8 Fedora Update System 2010-08-03 22:28:38 UTC
mock-1.0.10-1.el5 has been submitted as an update for Fedora EPEL 5.
http://admin.fedoraproject.org/updates/mock-1.0.10-1.el5

Comment 9 Fedora Update System 2010-08-03 22:29:42 UTC
mock-1.0.10-1.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/mock-1.0.10-1.fc12

Comment 10 Fedora Update System 2010-08-04 23:04:14 UTC
mock-1.0.10-1.el5 has been pushed to the Fedora EPEL 5 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update mock'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/mock-1.0.10-1.el5

Comment 11 Fedora Update System 2010-08-05 14:22:02 UTC
mock-1.1.3-1.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update mock'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/mock-1.1.3-1.fc14

Comment 12 Fedora Update System 2010-08-05 23:35:45 UTC
mock-1.1.3-1.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update mock'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/mock-1.1.3-1.fc13

Comment 13 Fedora Update System 2010-08-05 23:37:16 UTC
mock-1.0.10-1.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update mock'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/mock-1.0.10-1.fc12

Comment 14 Fedora Update System 2010-08-07 23:23:18 UTC
mock-1.1.3-1.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 15 Fedora Update System 2010-08-19 17:21:25 UTC
mock-1.1.4-1.fc14 has been submitted as an update for Fedora 14.
http://admin.fedoraproject.org/updates/mock-1.1.4-1.fc14

Comment 16 Fedora Update System 2010-08-19 17:22:31 UTC
mock-1.1.4-1.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/mock-1.1.4-1.fc13

Comment 17 Fedora Update System 2010-08-19 17:33:19 UTC
mock-1.0.11-1.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/mock-1.0.11-1.fc12

Comment 18 Fedora Update System 2010-08-19 17:34:37 UTC
mock-1.0.11-1.el5 has been submitted as an update for Fedora EPEL 5.
http://admin.fedoraproject.org/updates/mock-1.0.11-1.el5

Comment 19 Fedora Update System 2010-08-23 21:58:26 UTC
mock-1.1.4-1.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 20 Fedora Update System 2010-08-24 01:28:43 UTC
mock-1.1.4-1.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 21 Fedora Update System 2010-08-26 01:03:28 UTC
mock-1.0.11-1.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 22 Fedora Update System 2010-09-20 14:43:26 UTC
mock-1.0.12-1.fc12 has been submitted as an update for Fedora 12.
https://admin.fedoraproject.org/updates/mock-1.0.12-1.fc12

Comment 23 Fedora Update System 2010-09-20 14:44:58 UTC
mock-1.0.12-1.el5 has been submitted as an update for Fedora EPEL 5.
https://admin.fedoraproject.org/updates/mock-1.0.12-1.el5

Comment 24 Fedora Update System 2010-10-20 15:45:18 UTC
mock-1.0.13-1.el5 has been submitted as an update for Fedora EPEL 5.
https://admin.fedoraproject.org/updates/mock-1.0.13-1.el5

Comment 25 Fedora Update System 2010-10-20 15:47:30 UTC
mock-1.0.13-1.fc12 has been submitted as an update for Fedora 12.
https://admin.fedoraproject.org/updates/mock-1.0.13-1.fc12

Comment 26 Fedora Update System 2010-12-14 16:15:28 UTC
mock-1.0.14-1.el5 has been submitted as an update for Fedora EPEL 5.
https://admin.fedoraproject.org/updates/mock-1.0.14-1.el5

Comment 27 Fedora Update System 2011-01-18 20:05:43 UTC
mock-1.0.15-1.el5 has been submitted as an update for Fedora EPEL 5.
https://admin.fedoraproject.org/updates/mock-1.0.15-1.el5

Comment 28 Fedora Update System 2011-02-20 02:27:52 UTC
mock-1.1.9-1.fc13 has been submitted as an update for Fedora 13.
https://admin.fedoraproject.org/updates/mock-1.1.9-1.fc13

Comment 29 Fedora Update System 2011-02-20 02:30:54 UTC
mock-1.0.16-1.el5 has been submitted as an update for Fedora EPEL 5.
https://admin.fedoraproject.org/updates/mock-1.0.16-1.el5

Comment 30 Fedora Update System 2011-02-20 02:33:41 UTC
mock-1.1.9-1.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/mock-1.1.9-1.el6

Comment 31 Fedora Update System 2011-02-20 02:36:31 UTC
mock-1.1.9-1.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/mock-1.1.9-1.fc14

Comment 32 Fedora Update System 2011-03-03 08:26:47 UTC
mock-1.1.9-1.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 33 Fedora Update System 2011-03-03 08:35:22 UTC
mock-1.1.9-1.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 34 Fedora Update System 2011-05-13 20:35:47 UTC
mock-1.1.10-1.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/mock-1.1.10-1.fc15

Comment 35 Fedora Update System 2011-05-13 20:40:02 UTC
mock-1.1.10-1.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/mock-1.1.10-1.fc14

Comment 36 Fedora Update System 2011-05-13 20:44:19 UTC
mock-1.0.17-1.el5 has been submitted as an update for Fedora EPEL 5.
https://admin.fedoraproject.org/updates/mock-1.0.17-1.el5

Comment 37 Fedora Update System 2011-05-13 20:48:36 UTC
mock-1.1.10-1.fc13 has been submitted as an update for Fedora 13.
https://admin.fedoraproject.org/updates/mock-1.1.10-1.fc13

Comment 38 Fedora Update System 2011-05-13 20:53:00 UTC
mock-1.1.10-1.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/mock-1.1.10-1.el6

Comment 39 Fedora Update System 2011-05-19 04:37:05 UTC
mock-1.1.10-1.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 40 Fedora Update System 2011-05-25 02:44:22 UTC
mock-1.1.10-1.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 41 Fedora Update System 2011-05-25 03:18:31 UTC
mock-1.1.10-1.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 42 Fedora Update System 2011-06-02 19:08:34 UTC
mock-1.0.17-1.el5 has been pushed to the Fedora EPEL 5 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 43 Fedora Update System 2011-06-02 19:18:24 UTC
mock-1.1.10-1.el6 has been pushed to the Fedora EPEL 6 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.