Bug 60718 - RFE: Package dependency problem: A package providing libpisock.so.4 could not be found
RFE: Package dependency problem: A package providing libpisock.so.4 could not...
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: up2date (Show other bugs)
7.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Adrian Likins
Jay Turner
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-03-05 09:05 EST by Toni Willberg
Modified: 2015-01-07 18:55 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-03-05 10:49:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Toni Willberg 2002-03-05 09:05:33 EST
Description of problem:

up2date -u stopped working at some point, perhaps after I installed Ximian Gnome
and updated several components using Ximian Red-Carpet.


Version-Release number of selected component (if applicable):

up2date-2.7.11-7.x.2
rpm-4.0.3-1.03


How reproducible:
Always


Steps to Reproduce:

up2date -u


Actual Results:  

Retrieving list of all available packages...
########################################

Removing installed packages from list of updates...
########################################

Removing packages marked to skip from list...
########################################

Getting headers for available packages...
########################################

Removing packages with files marked to skip from list...
########################################

Testing package set / solving RPM inter-dependencies...
There was a package dependency problem.  The message was:
A package providing libpisock.so.4 could not be found.
Comment 1 Toni Willberg 2002-03-05 09:10:55 EST
It would be nice to know which .rpm caused the dependency problem.

I did not find any way to ask up2date to be more verbose. Something like -debug
would be nice...
Comment 2 Mihai Ibanescu 2002-03-05 10:49:49 EST
libpisock.so.4 was never provided by Red Hat. It comes from pilot-link (the
current Red Hat release is pilot-link-0.9.5-8). It's a conflict with the
packages provided by Red Carpet.

I will mark this bug as an enhancement request, since a sensible error message
is indeed more useful. Feel free to change it back and provide us with more
information if you notice something else is not behaving.

Note You need to log in before you can comment on or make changes to this bug.