Bug 607182 - installer has erroneous fqdn check
Summary: installer has erroneous fqdn check
Status: CLOSED DEFERRED
Alias: None
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Installer   
(Show other bugs)
Version: 530
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Milan Zázrivec
QA Contact: Red Hat Satellite QA List
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 462714
TreeView+ depends on / blocked
 
Reported: 2010-06-23 13:14 UTC by Dennis Gilmore
Modified: 2015-05-29 20:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-05-29 20:11:09 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Dennis Gilmore 2010-06-23 13:14:23 UTC
Description of problem:

running install.pl I encountered 
satellite.test doesn't have 3 fields (111.222.333). Can't be FQDN.
Use --skip-fqdn-test to bypass this error.

this check is completely erroneous and really gains nothing.

internally i could use say .corp  and i want my satellite box to be satellite.corp.  then if i were in the uk and wanted to use my public domain   of foo.co.uk and call my box satellite.foo.co.uk  the check wont make sure that i don't accidently call it foo.co.uk since it is valid according to the bogus assumptions made in the install.pl script.  I think that the check should just be removed as there is no way to reliably determine if the fqdn is really valid or not as that will vary widely depending on the environment.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:


Note You need to log in before you can comment on or make changes to this bug.