Bug 607232 - Stopped systemtap initscript does not start on 'restart'
Summary: Stopped systemtap initscript does not start on 'restart'
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: systemtap   
(Show other bugs)
Version: 5.5
Hardware: All
OS: Linux
low
medium
Target Milestone: rc
: ---
Assignee: Frank Ch. Eigler
QA Contact: qe-baseos-tools
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-06-23 14:59 UTC by Petr Muller
Modified: 2016-09-20 02:07 UTC (History)
4 users (show)

Fixed In Version: systemtap-1.3-5.el5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 607227
Environment:
Last Closed: 2011-07-21 11:11:00 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2011:1044 normal SHIPPED_LIVE systemtap bug fix update 2011-07-20 15:43:43 UTC

Description Petr Muller 2010-06-23 14:59:34 UTC
+++ This bug was initially created as a clone of Bug #607227 +++

Description of problem:

systemtap service from systemtap-initscript service does not beahve as required in https://fedoraproject.org/wiki/Packaging/SysVInitScript (the guideline is from Fedora, but it valid for RHEL too)

===============================================================================
All SysV-style initscripts in Fedora must have implementations of the following actions:
(...)
    * restart: stop and restart the service if the service is already running, otherwise just start the service
(...)
===============================================================================


Version-Release number of selected component (if applicable):
systemtap-1.2-3.el6

How reproducible:
always

Steps to Reproduce:
1. cp heart.stp /etc/systemtap/script.d/
2. service systemtap stop
3. service systemtap restart
  
Actual results:
# service systemtap restart
Starting systemtap:                                        [WARNING]
# service systemtap status
heart is stopped

Expected results:
# service systemtap restart
Starting systemtap:  Starting heart ... done
# service systemtap status
heart is running...

Comment 1 Petr Muller 2010-06-23 15:00:10 UTC
Reported for:

systemtap-1.1-3.el5

Comment 2 Frank Ch. Eigler 2010-07-12 19:47:34 UTC
We don't have a patch for this one yet, but it's bound to be a small easy one.

Comment 3 David Smith 2010-08-10 17:47:40 UTC
There appears to be a bug in the initscript's logic when it redefines the "SCRIPTS" variable.  When this problem happens, you'll see the following message in /var/log/messages:

  Warning: No scripts exist.

Note that you can immediately turn around and run "service systemtap start" which will work correctly.

Comment 5 Petr Muller 2010-10-19 14:17:29 UTC
This one seems to fall through the cracks... Because it has all the acks, and comment 4 + fact that systemtap was rebased in rhel5.6 should mean this is fixed in rhel5.6, I'll be bold, move this to MODIFIED and add to 5.6 erratum. Swear and revert if you dont agree :)

Comment 7 Petr Muller 2010-12-09 17:04:40 UTC
It seems like I did an error in comment 5, as this is not fixed, and the change mentioned in comment 4 did not get in:

# grep "condres" /etc/init.d/systemtap
# echo $?
1

Given this is really low prio, not a regression and not driven by customer, I'll remove this from the erratum and flag it for 5.7

Comment 9 RHEL Product and Program Management 2011-01-11 20:45:07 UTC
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.

Comment 10 RHEL Product and Program Management 2011-01-12 15:13:41 UTC
This request was erroneously denied for the current release of
Red Hat Enterprise Linux.  The error has been fixed and this
request has been re-proposed for the current release.

Comment 13 errata-xmlrpc 2011-07-21 11:11:00 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2011-1044.html


Note You need to log in before you can comment on or make changes to this bug.