Bug 607289 - eio and enospc mix when test " pasue on no space scenario "
eio and enospc mix when test " pasue on no space scenario "
Status: CLOSED DUPLICATE of bug 607688
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: qemu-kvm (Show other bugs)
6.0
All Linux
low Severity medium
: rc
: ---
Assigned To: Kevin Wolf
Virtualization Bugs
:
Depends On:
Blocks: 580953
  Show dependency treegraph
 
Reported: 2010-06-23 13:30 EDT by lihuang
Modified: 2010-06-25 07:58 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-25 07:58:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
qmplog.txt (108.18 KB, text/plain)
2010-06-23 13:30 EDT, lihuang
no flags Details

  None (edit)
Description lihuang 2010-06-23 13:30:04 EDT
Created attachment 426321 [details]
qmplog.txt

Description of problem:
Attached please find the QMP notification on "STOP" event.
you can find the enospc and eio raise in order . enospc -> eio -> enospc -> eio ...


CLI:
/usr/libexec/qemu-kvm -M rhel6.0.0 -enable-kvm -m 4096 -smp 2,sockets=2,cores=1,threads=1 -name s6.17 
-uuid 4118213c-7344-e8a4-68e5-23097f37fff5 -nodefaults -rtc base=utc -boot c 
-drive file=/data/t179/images/s6.17.img.running,if=none,id=drive-virtio-disk0,boot=on,format=qcow2,werror=stop,rerror=stop        \
-device virtio-blk-pci,bus=pci.0,addr=0x4,drive=drive-virtio-disk0,id=virtio-disk0                                     \
-drive file=/dev/vgtest/lvtest,if=none,id=drive-virtio-disk1,format=qcow2,werror=stop,rerror=stop                \
-device virtio-blk-pci,bus=pci.0,drive=drive-virtio-disk1,id=virtio-disk1
-netdev tap,id=hostnet0,vhost=on -device virtio-net-pci,netdev=hostnet0,id=net0,mac=52:54:00:aa:a7:b1,bus=pci.0 -usb -device usb-tablet,id=input0 -vnc :1 -vga cirrus -device virtio-balloon-pci,id=balloon0,bus=pci.0 -qmp tcp:0:4444,server

Version-Release number of selected component (if applicable):
qemu-kvm-0.12.1.2-2.77.el6.x86_64


How reproducible:
1/1  (7 eio and 7 enospc) 




Steps to Reproduce:
1.the lvm /dev/vgtest/lvtest  start with 1G,and extend 1G on each "STOP"

[root@t78 ~]# vgs
  VG     #PV #LV #SN Attr   VSize   VFree  
  vg_t78   1   3   0 wz--n- 465.27g      0 
  vgtest   1   1   0 wz--n- 144.92g 129.92g
[root@t78 ~]# lvs
  LV      VG     Attr   LSize   Origin Snap%  Move Log Copy%  Convert
  lv_home vg_t78 -wi-ao 405.46g                                      
  lv_root vg_t78 -wi-ao  50.00g                                      
  lv_swap vg_t78 -wi-ao   9.81g                                      
  lvtest  vgtest -wi-ao   1.00g                                      
2.qcow2 image is create as 30G:
[root@t78 ~]# qemu-img info -f qcow2 /dev/vgtest/lvtest
image: /dev/vgtest/lvtest
file format: qcow2
virtual size: 30G (32212254720 bytes)
disk size: 0
cluster_size: 65536

3.start guest with the given command line.

4.inside guest.
write to the second disk. dd if=/dev/zeor of=/mnt/a.out bs=1M count=15000

5.wait for vm pasue on ENOSPC/EIO.

6.lvextend -L +1G /dev/vgtest/lvtest

7.resume guest with QMP command   {"execute": "cont"}


Actual results:


Expected results:


Additional info:

after testing .qemu-img check report same error:
ERROR cluster 213011 refcount=1 reference=0
826 errors were found on the image.
Comment 2 RHEL Product and Program Management 2010-06-23 13:52:57 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 3 Kevin Wolf 2010-06-25 07:58:45 EDT
I can reproduce on rhel6/master, but not on rhel6/next. It seems to be fixed accidentally with the patches for bug 607688, so I'm closing this one as a duplicate.

*** This bug has been marked as a duplicate of bug 607688 ***

Note You need to log in before you can comment on or make changes to this bug.