Bug 60729 - Matrox G450 video card is not detected post-intall
Matrox G450 video card is not detected post-intall
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: Xconfigurator (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-03-05 13:12 EST by Ben Levenson
Modified: 2007-04-18 12:40 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-03-22 11:13:05 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ben Levenson 2002-03-05 13:12:05 EST
Description of Problem:
Matrox Mellennium G450 video card was properly detected during installation;
but running Xconfigurator post-install presents me with the "Choose a Card"
screen. 

Version-Release number of selected component (if applicable):
Xconfigurator-4.9.43-1
XFree86-4.2.0-6.39

How Reproducible:
100%

Steps to Reproduce:
1. install, card is detected as expected (though it only detects 16MB)
2. run Xconfigurator post install.
3. choose card.

Additional Info:
01:00.0 VGA compatible controller: Matrox Graphics, Inc. MGA G400 AGP (rev 82)
(prog-if 00 [VGA])
        Subsystem: Matrox Graphics, Inc. Millennium G450 Dual Head
        Flags: bus master, medium devsel, latency 64, IRQ 11
        Memory at e2000000 (32-bit, prefetchable) [size=32M]
        Memory at e1000000 (32-bit, non-prefetchable) [size=16K]
        Memory at e0800000 (32-bit, non-prefetchable) [size=8M]
        Expansion ROM at e1fe0000 [disabled] [size=128K]
        Capabilities: [dc] Power Management version 2
        Capabilities: [f0] AGP version 2.0
Comment 1 Mike A. Harris 2002-03-06 18:40:21 EST
It is not possible to detect RAM on these boards.
Also, the G400 and G450 use the same PCI ID.
Comment 2 Jay Turner 2002-03-20 21:21:25 EST
So it's prompted for the user to choose the card because there are two with the
same ID?
Comment 3 Mike A. Harris 2002-03-21 22:49:07 EST
No..  The G400 and G450 will both show up in the X log as being a G400.
The PCI ID's and subid's of these cards are in the pcitable correctly and
will detect properly.  What is displayed by lspci and X, will be G400.
This is because Matrox chose to not change the PCI id.  Inside the mga
driver however it distinguishes between the two using the subid/rev
properly.  New versions of XFree86 handle the purely cosmetic issue
of displaying G450 properly by checking for the subid/rev.

If you notice in the above lspci output, the first line shows G400, and
the second line shows G450.  This info, while confusing is correct.

The problem I see being reported is that Xconfigurator is not detecting
this card when ran standalone post-install.  I've had at least 4 reports
of this behaviour in the last few weeks from various people, and in all
cases so far, upgrading to the latest hwdata and Xconfigurator packages
has solved the problem.  I believe it was just a case of beta to beta
upgrade failure.  Please test with the latest packages and if it works
properly close for RAWHIDE.

THanks.
Comment 4 Ben Levenson 2002-03-22 11:13:00 EST
right'o. will test later this afternoon.
Changing to NEEDINFO to help me remember to follow up on this.
Comment 5 Ben Levenson 2002-03-22 15:35:48 EST
hwdata-0.8-3
Xconfigurator-4.10.1-10
everything works as expected. CLOSING -> RAWHIDE

Note You need to log in before you can comment on or make changes to this bug.