Bugzilla will be upgraded to version 5.0 on December 2, 2018. The outage period for the upgrade will start at 0:00 UTC and have a duration of 12 hours
Bug 607318 - [abrt] crash in dwscan-0.2-4.fc12: iwlibs.py:1010:_fcntl:IOError: [Errno 95] Operation not supported
[abrt] crash in dwscan-0.2-4.fc12: iwlibs.py:1010:_fcntl:IOError: [Errno 95] ...
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: dwscan (Show other bugs)
12
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Fabian Affolter
Fedora Extras Quality Assurance
abrt_hash:ce4a8495
:
: 637779 651817 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-23 15:25 EDT by Dave Merriman
Modified: 2010-11-18 06:32 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-09-06 18:04:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (1.05 KB, text/plain)
2010-06-23 15:25 EDT, Dave Merriman
no flags Details

  None (edit)
Description Dave Merriman 2010-06-23 15:25:25 EDT
abrt 1.0.9 detected a crash.

architecture: i686
cmdline: /usr/bin/python /usr/sbin/dwscan
comment: Initial attempt to run application from commandline
component: dwscan
executable: /usr/sbin/dwscan
kernel: 2.6.32.14-127.fc12.i686
package: dwscan-0.2-4.fc12
reason: iwlibs.py:1010:_fcntl:IOError: [Errno 95] Operation not supported
release: Fedora release 12 (Constantine)

backtrace
-----
iwlibs.py:1010:_fcntl:IOError: [Errno 95] Operation not supported

Traceback (most recent call last):
  File "/usr/sbin/dwscan", line 163, in <module>
    stats, quality, discard, missed_beacon = ifobj.getStatistics()
  File "/usr/lib/python2.6/site-packages/pythonwifi/iwlibs.py", line 666, in getStatistics
    iwstats = Iwstats(self.ifname)
  File "/usr/lib/python2.6/site-packages/pythonwifi/iwlibs.py", line 1119, in __init__
    self.update()
  File "/usr/lib/python2.6/site-packages/pythonwifi/iwlibs.py", line 1130, in update
    data=s)
  File "/usr/lib/python2.6/site-packages/pythonwifi/iwlibs.py", line 1023, in iw_get_ext
    result = self._fcntl(request, ifreq)
  File "/usr/lib/python2.6/site-packages/pythonwifi/iwlibs.py", line 1010, in _fcntl
    return fcntl.ioctl(self.sockfd.fileno(), request, args)
IOError: [Errno 95] Operation not supported

Local variables in innermost frame:
self: <pythonwifi.iwlibs.Iwstruct object at 0x920282c>
args: array('c', 'lo\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\xd8\x99 \t \x00\x00\x00')
request: 35599
Comment 1 Dave Merriman 2010-06-23 15:25:27 EDT
Created attachment 426369 [details]
File: backtrace
Comment 2 Fabian Affolter 2010-09-06 18:04:12 EDT
dwscan makes heavy usage of python-wifi.  The issue is that most modern wifi cards aren't supported by python-wifi at the moment.
Comment 3 Fabian Affolter 2010-10-10 09:40:49 EDT
*** Bug 637779 has been marked as a duplicate of this bug. ***
Comment 4 Fabian Affolter 2010-11-18 06:32:28 EST
*** Bug 651817 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.