Bug 607369 - Server freezes after the installation system is booted.
Server freezes after the installation system is booted.
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: kernel (Show other bugs)
6.0
x86_64 Linux
low Severity medium
: rc
: ---
Assigned To: Prarit Bhargava
Red Hat Kernel QE team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-23 19:06 EDT by vishal
Modified: 2010-10-12 09:26 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-10-12 09:26:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description vishal 2010-06-23 19:06:06 EDT
Description of problem:
Server installated with RHEL 6 Beta version freezes after user is logged in.

Version-Release number of selected component (if applicable):
Server Information:
HP Proliant DL380 G5 series. Latest firmware is installed on the server.

How reproducible:
Reproducible everytime.

Steps to Reproduce:
1. Installed RHEL 6 Beta X86_64
2. Installation is successful
3. Reboot the server after installation.
4. Create a non-administrative user.
5. Login to server using the user. 
6. Server freezes after about a minute or so later. 
7. No other option but to hard reset the server.
  
Actual results:
Server freezes after about a minute or so.

Expected results:
Server should not freeze.

Additional info:
Comment 2 Bill Nottingham 2010-06-24 12:35:31 EDT
Can you set up netconsole and see if you can get some errors logged?
Comment 3 vishal 2010-06-24 12:43:03 EDT
I am not aware of procedure to set up netconsole. Sorry.
Comment 4 RHEL Product and Program Management 2010-06-24 12:52:52 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 5 Prarit Bhargava 2010-07-05 10:26:45 EDT
(In reply to comment #3)
> I am not aware of procedure to set up netconsole. Sorry.    

Can you hook up a serial console and get some output that way?

Thanks,

P.
Comment 6 vishal 2010-07-06 10:58:25 EDT
Hello Prarit,

Unfortunately, I cannot get any logs on this issue at this time as we have  already downgraded the server back to RHEL 5.4. 

Is there a way that you could work with HP on addressing this issue?

Regards,
Vishal
Comment 7 Prarit Bhargava 2010-07-08 09:53:33 EDT
Vishal, 

It's possible -- but it would be best for you to obtain a boot log from your system and send it to us.

Thanks,

P.
Comment 8 vishal 2010-07-08 10:55:58 EDT
I understand but we have reverted the system back to previous release of RHEL. Hence there are no logs. On hind side, I should have captured the dmesg. But again the system would freeze giving me no oppurtunity to get any logs. If we do load another server with RHEL 6, I will make sure to capture the logs and send them to you. In the meantime, please work with HP.

Thank you,

Vishal
Comment 9 RHEL Product and Program Management 2010-07-15 10:24:28 EDT
This issue has been proposed when we are only considering blocker
issues in the current Red Hat Enterprise Linux release. It has
been denied for the current Red Hat Enterprise Linux release.

** If you would still like this issue considered for the current
release, ask your support representative to file as a blocker on
your behalf. Otherwise ask that it be considered for the next
Red Hat Enterprise Linux release. **
Comment 10 vishal 2010-10-05 18:54:34 EDT
Hi all,

We reloaded one of our servers with the latest RHEL 6 Beta 2 release. We noticed the kernel crash. Here is the log from the crash report:

WARNING: at arch/x86/kernel/cpu/mtrr/generic.c:467 generic_get_mtrr+0x11e/0x140() (Not tainted)
Hardware name: ProLiant DL380 G5
mtrr: your BIOS has set up an incorrect mask, fixing it up.
Modules linked in: radeon(+) ttm drm_kms_helper drm i2c_algo_bit i2c_core dm_mod
Pid: 143, comm: modprobe Not tainted 2.6.32-44.1.el6.x86_64 #1
Call Trace:
[<ffffffff8106a883>] warn_slowpath_common+0x83/0xc0
[<ffffffff8106a921>] warn_slowpath_fmt+0x41/0x50
[<ffffffff8102ba0e>] generic_get_mtrr+0x11e/0x140
[<ffffffff8102a53b>] mtrr_add_page+0xdb/0x470
[<ffffffff810d98f4>] ? request_threaded_irq+0x1d4/0x2f0
[<ffffffff8102a926>] mtrr_add+0x56/0x70
[<ffffffffa00ceade>] radeon_bo_init+0x2e/0x90 [radeon]
[<ffffffffa00ed4a3>] r100_init+0x103/0x2d0 [radeon]
[<ffffffff813218e2>] ? vga_client_register+0x82/0x90
[<ffffffffa00bad65>] radeon_device_init+0x275/0x370 [radeon]
[<ffffffffa00bc12f>] radeon_driver_load_kms+0x9f/0x1d0 [radeon]
[<ffffffffa003f4b8>] drm_get_dev+0x328/0x550 [drm]
[<ffffffffa012ea68>] radeon_pci_probe+0x15/0x293 [radeon]
[<ffffffff81270e07>] local_pci_probe+0x17/0x20
[<ffffffff81271ff1>] pci_device_probe+0x101/0x120
[<ffffffff81331e12>] ? driver_sysfs_add+0x62/0x90
[<ffffffff81331fb0>] driver_probe_device+0xa0/0x2a0
[<ffffffff8133225b>] __driver_attach+0xab/0xb0
[<ffffffff813321b0>] ? __driver_attach+0x0/0xb0
[<ffffffff81331214>] bus_for_each_dev+0x64/0x90
[<ffffffff81331d4e>] driver_attach+0x1e/0x20
[<ffffffff81331650>] bus_add_driver+0x200/0x300
[<ffffffff81332586>] driver_register+0x76/0x140
[<ffffffff81272256>] __pci_register_driver+0x56/0xd0
[<ffffffff814d7923>] ? printk+0x41/0x46
[<ffffffffa0039731>] drm_init+0x111/0x120 [drm]
[<ffffffffa0166000>] ? radeon_init+0x0/0xc1 [radeon]
[<ffffffffa01660bf>] radeon_init+0xbf/0xc1 [radeon]
[<ffffffff8100a04c>] do_one_initcall+0x3c/0x1d0
[<ffffffff810aeedf>] sys_init_module+0xdf/0x250
[<ffffffff81013172>] system_call_fastpath+0x16/0x1b

I tried to report this via automatic bug reporting but could not because debuginfo-install kernel could not install the kernel-debuginfo package.
Comment 11 Prarit Bhargava 2010-10-06 08:28:46 EDT
(In reply to comment #10)

> WARNING: at arch/x86/kernel/cpu/mtrr/generic.c:467
> generic_get_mtrr+0x11e/0x140() (Not tainted)
> Hardware name: ProLiant DL380 G5
> mtrr: your BIOS has set up an incorrect mask, fixing it up.
> Modules linked in: radeon(+) ttm drm_kms_helper drm i2c_algo_bit i2c_core
> dm_mod

Hi -- request a new BIOS from HP.

P.
Comment 12 Prarit Bhargava 2010-10-12 09:26:45 EDT
This is a BIOS issue, not a software issue.

Reporter should request an updated BIOS from HP to resolve the issue.

P.

Note You need to log in before you can comment on or make changes to this bug.