Bugzilla will be upgraded to version 5.0. The upgrade date is tentatively scheduled for 2 December 2018, pending final testing and feedback.
Bug 607392 - Evolution creates a copy of message instead of replacing
Evolution creates a copy of message instead of replacing
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
14
i386 Linux
low Severity low
: ---
: ---
Assigned To: Matthew Barnes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-23 21:29 EDT by Volans
Modified: 2011-06-02 02:28 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-05-27 23:16:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Bugzilla 651684 None None None Never

  None (edit)
Description Volans 2010-06-23 21:29:45 EDT
Description of problem:

Evolution creates a copy of a message, when the user changes the email account that he/she wishes to use to send the email, instead of changing just the used account.

Version-Release number of selected component (if applicable): 2.30.1.2


How reproducible: Read the steps


Steps to Reproduce:
1. Create a new email, using your default email account (you must have more than one account to experience this bug)
2. Press the "Send" button.
3. Open the "Outbox" folder and open the message, before it being sent.
4. Change the account you wish to use to send that email (example, change from the default one, to a secondary one).
5. Click on "Send".
6. A copy of the message is created, instead of replacement the original message

  
Actual results:

Two emails, from two different accounts, that are exactly the same are sent.


Expected results:


Additional info:

This bug started in Fedora 13. Didn't exist on Fedora 12.
Comment 1 Milan Crha 2011-05-31 00:03:41 EDT
Hi Volans, do you have a bug reference (URL) to an upstream bugzilla, where this one is moved to, please?
Comment 2 Volans 2011-06-01 07:07:27 EDT
Hello,

Well, I just closed this bug, together with other ones, because it was me who posted it and I thought it was solved. But actually, I checked now and the problem still happens, so I'm going to open it and change the program version.
Comment 3 Volans 2011-06-01 07:07:58 EDT
This bug still happens in version 2.32.2
Comment 4 Milan Crha 2011-06-01 08:24:40 EDT
This is still in Closed/Upstream state. Could you answer my question from comment #1, please?
Comment 5 Volans 2011-06-01 21:50:08 EDT
Hello Milan,

I thought this bug was fixed and since I posted it one year ago (Fedora 13), I closed it. Yesterday, after your comment, I reproduced the same procedure in Fedora 14 (in my old and updated computer) and the problem is still there. In one year, it wasn't fixed. So, it never actually went "upstream". I just closed the bug because no-one fixed it in such a long time and I had a too long list of posted bugs here (posted by me) and decided to eliminate some.

Since the new Evolution version, included in Fedora 15 (my new PC) keeps the window open, while sending the email, never putting the email on the Outbox, a message is never created there, so the bug is somewhat "eliminated". The feature which caused it, was changed.

So, I don't know. Keep the bug active, or delete it? It will never be fixed anyway, like many Linux bugs, even the most obvious and easy to track. I know that by experience, trust me. Sometimes I wish I could make Linux programing, compiling and debugging myself, so I could fix at least the most obvious bugs myself. They are annoying.

I can't open the bug again. If you want, you need to go it yourself. I only have "Assigned" as option, opposite to "Closed" option.

Regards
Comment 6 Milan Crha 2011-06-02 02:28:17 EDT
Ah, thanks for the update. The Closed/Upstream is mainly used when the bug is moved to the upstream bugzilla, and then a bugzilla link is usually included for a reference. Other closed states can be used when the bug wasn't actually moved to the upstream.

Anyway, I can reproduce the bug in 3.0.x when the evolution is in an offline mode. I moved this upstream as [1]. Please use it for any further updates.

[1] https://bugzilla.gnome.org/show_bug.cgi?id=651684

Note You need to log in before you can comment on or make changes to this bug.