Bug 6074 - Kernel 2.2.5-15 dereferences null pointer
Kernel 2.2.5-15 dereferences null pointer
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
6.0
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Michael K. Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-10-18 22:29 EDT by ghn
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-01-04 17:27:39 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description ghn 1999-10-18 22:29:53 EDT
After installing RH6.0 on a machine that had been happily
running 5.1 for several months, I have run into a problem.
Another user (rdnelson@princeton.edu) reports a similar
problem.  Running with an off-the-shelf 6.0 kernel
(2.2.5-15.i586) on an AMD K6-2/333 with 32M memory, the
machine locked up with the following message in
/var/log/messages:

Oct  7 17:36:50 mercury kernel: Unable to handle kernel NULL
pointer dereference at virtual address 00000004

For both of us, this problem seemed to occur while using
Netscape Communicator.  I have since upgraded to 2.2.5-22
and have not seen the problem again, but I don't know what
web site/page I was looking at that caused the problem
initially, or even if it was data-dependent.

I have been unable to determine what changes occurred
between release 15 and release 22, though the upgrade center
indicates 22 fixes a potential for "remotely hanging the
machine".

Could someone verify whether this is a known or fixed
problem?
Comment 1 Bill Nottingham 1999-10-19 10:49:59 EDT
We'd need more information. If you could run the full oops text
through ksymoops, it would be helpful.
Comment 2 Bill Nottingham 1999-11-04 18:22:59 EST
Does the 2.2.12 kernel from 6.1 still have this problem?
Comment 3 Cristian Gafton 2000-01-04 17:27:59 EST
Assigned to dledford
Comment 4 Alan Cox 2000-08-08 09:52:58 EDT
Closed in the absence of further traffic

Note You need to log in before you can comment on or make changes to this bug.