Bug 607410 - Reproducible stuck grab on server
Reproducible stuck grab on server
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: xorg-x11-server (Show other bugs)
6.0
All Linux
low Severity medium
: rc
: ---
Assigned To: Peter Hutterer
desktop-bugs@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-23 23:35 EDT by Peter Hutterer
Modified: 2010-11-10 16:59 EST (History)
1 user (show)

See Also:
Fixed In Version: xorg-x11-server-1.7.7-16.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-10 16:59:07 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
$HOME/.mwmrc (2.36 KB, text/plain)
2010-06-23 23:35 EDT, Peter Hutterer
no flags Details

  None (edit)
Description Peter Hutterer 2010-06-23 23:35:45 EDT
Created attachment 426446 [details]
$HOME/.mwmrc

Description of problem:
Passive button grabs can get stuck, resulting in an unresponsive desktop. One reproducer is described below, there are likely other applications that trigger the same behaviour.

Version-Release number of selected component (if applicable):
xorg-x11-server-1.7.7-12.el6.x86_64

How reproducible:
Install the mwm window manager and install the $HOME/.mwmrc attached. Start up a plain X server, mwm and two xterms. Then hit Alt+mouse button1 over one of the terminals. The mouse is now unresponsive.

Steps to Reproduce:
1. start a plain X server
2. start mpwm
3. start two xterms
4. press Alt+Button1
5. desktop is unresponsive
 
Additional info:
Seems to be caused by invalid ButtonPress event delivery when a passive grab without the ButtonPress mask is activated.
Comment 1 RHEL Product and Program Management 2010-06-23 23:52:52 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 2 Peter Hutterer 2010-06-28 20:30:55 EDT
MODIFIED

xorg-x11-server-1.7.7-16.el6 is available in brew.
Comment 4 Radek Lat 2010-11-08 12:42:19 EST
Tested and Verified using reproducer from comment 0 on xorg-x11-server-common-1.7.7-26.el6.
Moving to VERIFIED.
Comment 5 releng-rhel@redhat.com 2010-11-10 16:59:07 EST
Red Hat Enterprise Linux 6.0 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.

Note You need to log in before you can comment on or make changes to this bug.