This service will be undergoing non-disruptive maintenance at 07:20 UTC, 2018-12-14. It is expected to last approximately 30 minutes
Bug 60749 - path to mysql.sock not set with php-4.0.6-12 errata upadate
Summary: path to mysql.sock not set with php-4.0.6-12 errata upadate
Status: CLOSED DUPLICATE of bug 60515
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: php (Show other bugs)
(Show other bugs)
Version: 7.2
Hardware: i386 Linux
medium
low
Target Milestone: ---
Assignee: Phil Copeland
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-03-05 21:54 UTC by Need Real Name
Modified: 2007-04-18 16:40 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-03-05 21:54:55 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Need Real Name 2002-03-05 21:54:50 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.2.1) Gecko/20010901

Description of problem:
The most recent update to php, php-4.0.6-12, fails to set the proper path in
php.ini in /var/lib/mysql/mysql.sock and the default is used, /tmp/mysql.sock...
which is wrong and you get errors and such.

the rpms installed are:
php-4.0.6-12.i386.rpm
php-mysql-4.0.6-12.i386.rpm

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.update using the various php-4.0.6-12 rpms
2.try to access your mysql database's through a php interface

	

Actual Results:  3.you get errors "/var/mysql.sock could not be found" etc.

Expected Results:  pages load as they did moments before you updated the php
packages.

Additional info:

open php.ini and add:
mysql.default_socket =/var/lib/mysql/mysql.sock

and restart apache:
/etc/rc.d/init.d/httpd restart

success!

this only took me a short time to fix, but i know it would have made me pull my
hair out a few years back... hope it helps someone...

Comment 1 Phil Copeland 2002-03-06 07:41:07 UTC

*** This bug has been marked as a duplicate of 60515 ***


Note You need to log in before you can comment on or make changes to this bug.