Bug 607514 - SELinux is preventing /usr/bin/nautilus "getattr" access on /proc/mdstat.
SELinux is preventing /usr/bin/nautilus "getattr" access on /proc/mdstat.
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
13
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
setroubleshoot_trace_hash:5c50ac20ecf...
:
: 607522 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-24 05:52 EDT by trevor
Modified: 2010-07-06 13:09 EDT (History)
2 users (show)

See Also:
Fixed In Version: selinux-policy-3.7.19-33.fc13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-06 13:09:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description trevor 2010-06-24 05:52:23 EDT
Summary:

SELinux is preventing /usr/bin/nautilus "getattr" access on /proc/mdstat.

Detailed Description:

SELinux denied access requested by nautilus. It is not expected that this access
is required by nautilus and this access may signal an intrusion attempt. It is
also possible that the specific version or configuration of the application is
causing it to require additional access.

Allowing Access:

You can generate a local policy module to allow this access - see FAQ
(http://docs.fedoraproject.org/selinux-faq-fc5/#id2961385) Please file a bug
report.

Additional Information:

Source Context                xguest_u:xguest_r:xguest_t:s0
Target Context                system_u:object_r:proc_mdstat_t:s0
Target Objects                /proc/mdstat [ file ]
Source                        nautilus
Source Path                   /usr/bin/nautilus
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           nautilus-2.30.1-3.fc13
Target RPM Packages           
Policy RPM                    selinux-policy-3.7.19-23.fc13
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Plugin Name                   catchall
Host Name                     (removed)
Platform                      Linux (removed) 2.6.33.5-124.fc13.i686
                              #1 SMP Fri Jun 11 09:48:40 UTC 2010 i686 i686
Alert Count                   2
First Seen                    Tue 22 Jun 2010 09:18:06 EST
Last Seen                     Tue 22 Jun 2010 09:18:14 EST
Local ID                      86c1ec39-9939-41dc-b86f-0dd17ca6a2fe
Line Numbers                  

Raw Audit Messages            

node=(removed) type=AVC msg=audit(1277162294.697:22936): avc:  denied  { getattr } for  pid=11954 comm="nautilus" path="/proc/mdstat" dev=proc ino=4026531929 scontext=xguest_u:xguest_r:xguest_t:s0 tcontext=system_u:object_r:proc_mdstat_t:s0 tclass=file

node=(removed) type=SYSCALL msg=audit(1277162294.697:22936): arch=40000003 syscall=196 success=no exit=-13 a0=b6a0d7a0 a1=b75d7f6c a2=7e4ff4 a3=b1e13bc8 items=0 ppid=11468 pid=11954 auid=502 uid=502 gid=502 euid=502 suid=502 fsuid=502 egid=502 sgid=502 fsgid=502 tty=(none) ses=4 comm="nautilus" exe="/usr/bin/nautilus" subj=xguest_u:xguest_r:xguest_t:s0 key=(null)



Hash String generated from  catchall,nautilus,xguest_t,proc_mdstat_t,file,getattr
audit2allow suggests:

#============= xguest_t ==============
allow xguest_t proc_mdstat_t:file getattr;
Comment 1 Miroslav Grepl 2010-06-24 06:59:18 EDT
Did this happen by default or were you using nautilus to look at /proc?
Comment 2 Miroslav Grepl 2010-06-24 07:00:14 EDT
Dan,
we don't audit it in F12.
Comment 3 trevor 2010-06-24 18:20:56 EDT
This happened by default.
Comment 4 Miroslav Grepl 2010-06-25 07:32:26 EDT
*** Bug 607522 has been marked as a duplicate of this bug. ***
Comment 5 Daniel Walsh 2010-06-25 13:36:35 EDT
Should dontaudit it.
Comment 6 Daniel Walsh 2010-06-25 14:06:07 EDT
	kernel_dontaudit_list_all_proc($1_usertype)
in 

template(`userdom_login_user_template', `
Comment 7 Miroslav Grepl 2010-06-28 10:16:51 EDT
Fixed in selinux-policy-3.7.19-32.fc13
Comment 8 Fedora Update System 2010-06-30 15:54:59 EDT
selinux-policy-3.7.19-33.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/selinux-policy-3.7.19-33.fc13
Comment 9 Fedora Update System 2010-07-01 14:48:57 EDT
selinux-policy-3.7.19-33.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update selinux-policy'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/selinux-policy-3.7.19-33.fc13
Comment 10 Fedora Update System 2010-07-06 13:07:17 EDT
selinux-policy-3.7.19-33.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.