Bug 607544 - Document diskless system deployment
Document diskless system deployment
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: doc-Storage_Admin_Guide (Show other bugs)
6.0
All Linux
low Severity medium
: rc
: ---
Assigned To: Don Domingo
ecs-bugs
: Documentation
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-24 06:49 EDT by Jaroslav Reznik
Modified: 2010-11-11 10:36 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-11 10:36:36 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Diskless guide draft (4.18 KB, application/octet-stream)
2010-06-24 06:49 EDT, Jaroslav Reznik
no flags Details

  None (edit)
Description Jaroslav Reznik 2010-06-24 06:49:53 EDT
Created attachment 426523 [details]
Diskless guide draft

Description of problem: document diskless system deployment as system-config-netboot has been removed from RHEL 6. Maybe it's more suitable for Migration guide?

Draft in attachment.

Expected results:
RHEL 6 diskless system deployment guide.
Comment 1 Jaroslav Reznik 2010-06-24 06:51:18 EDT
Reference bz - https://bugzilla.redhat.com/show_bug.cgi?id=588608.
Comment 3 RHEL Product and Program Management 2010-06-24 07:13:49 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 4 Douglas Silas 2010-06-24 08:53:03 EDT
After discussing this bug with Jaroslav, we decided that this may be a candidate for the Storage Admin Guide. I am going to tentatively reassign this bug to that component.
Comment 5 Don Domingo 2010-06-24 18:45:04 EDT
thanks Jaroslav, Silas; marking for 6.1 at the latest. i will let you guys know if we can deliver it earlier for a tech review.
Comment 6 Jaroslav Reznik 2010-06-25 04:14:00 EDT
(In reply to comment #5)
> thanks Jaroslav, Silas; marking for 6.1 at the latest. i will let you guys know
> if we can deliver it earlier for a tech review.    

Hi Don,
would be great to have it as soon as possible as we removed system-config-netboot from RHEL-6 and customers are complaining but we can't bring it back (it's outdated tool, rewrite would be needed). We already tried to remove it from RHEL-5 but it came back there and we don't want this situation again in RHEL-6.

I can help you on technical side but my documentation skills are weak. This is very first draft but would be great to finish it soon - I know it's really very late for RHEL-6 but it's based on customer request - see https://bugzilla.redhat.com/show_bug.cgi?id=588608 comments.

Thanks,
Jaroslav
Comment 7 Don Domingo 2010-06-28 00:48:02 EDT
hi Jaroslav, i understand the urgency now. please review a draft on the chapter in the following link:

http://brisvegas.bne.redhat.com/rhel6-storageguide/nfs-diskless-systems.html

i made several edits, particulary in the commands used for:

http://brisvegas.bne.redhat.com/rhel6-storageguide/diskless-nfs-config.html

please advise if the chapter's okay. if it's good to go, please let me know so we can squeeze this through QE and make it to RHEL6.0.
Comment 8 Jaroslav Reznik 2010-06-28 05:39:19 EDT
Great, thanks! I'm going to review it now, Phil Knirsch asked me to add more dracut related info from the original report bug written by Harald Hoyer, I ask him to help with review/advises too.
Comment 23 Kai Meyer 2010-08-03 11:52:24 EDT
We are also very eagerly anticipating a usable NFSRoot guide for RHEL6. One of the features of s-c-netboot that I don't see a mention of in the posted guide was the idea of "snapshot" files. There is a need to have a set of files to be unique on each Root file system, and it's needless to have an entirely new root directory for each diskless server. The way s-c-netboot accomplished this was to separate the read-only root filesystem from the files that each server needs to have writable and/or unique. The read-write nfs mount point would be mounted in '/.snapshot' and then directories from inside that mount point were then mounted over the top of the read-only files with "mount --bind". We are digging into the dracut documentation, but having difficulty discovering a documented way to duplicate this sort of behavior. We would even be happy with documentation on "If you want to do that, write your script and put it here."
Comment 24 Harald Hoyer 2010-08-03 11:57:35 EDT
(In reply to comment #23)
> to have writable and/or unique. The read-write nfs mount point would be mounted
> in '/.snapshot' and then directories from inside that mount point were then
> mounted over the top of the read-only files with "mount --bind". We are digging

Does this have to be done with dracut? I thought, if

/etc/sysconfig/readonly-root
/etc/rwtab
/etc/fstab

are setup according to your idea, /etc/rc.sysinit will do the right thing.
Comment 25 Kai Meyer 2010-08-03 12:30:06 EDT
That is some very promising information. I am not familiar with /etc/sysconfig/readonly-root or /etc/rwtab, but just their names is enough to give me hope. I'll go digging through documentation to see if I can make it fit our needs.

I wouldn't say this has to be done with dracut. I think it is just that s-c-netboot modified the initrd with a shell script that does all the unique/rw "mount --bind" commands for you based on the contents of a file called "files" in your rw nfs "snapshot" directory. Since dracut and initramfs are replacing s-c-netboot and initrd (among others I'm sure), it just feels natural that dracut would have something similar. But I really don't care if it's not dracut, just so long as I am able to get the job done.

To me, the most valuable reason to do NFS root is to be able to have multiple diskless systems running identical operating systems, with the exception of configuration files for hostname, ip, ect. A single 'yum --install-root=... update' from the NFS server would update all systems at the same time. I am not as concerned with making sure that the root filesystem is read-only, as I am with making sure that the majority of the system's root directory is shared between "clients" to save on storage as well as time on some Administrative tasks.
Comment 26 trbuschbach 2010-09-04 11:32:32 EDT
(In reply to comment #25)
> That is some very promising information. I am not familiar with
> /etc/sysconfig/readonly-root or /etc/rwtab, but just their names is enough to
> give me hope. I'll go digging through documentation to see if I can make it fit
> our needs.
> 
> I wouldn't say this has to be done with dracut. I think it is just that
> s-c-netboot modified the initrd with a shell script that does all the unique/rw
> "mount --bind" commands for you based on the contents of a file called "files"
> in your rw nfs "snapshot" directory. Since dracut and initramfs are replacing
> s-c-netboot and initrd (among others I'm sure), it just feels natural that
> dracut would have something similar. But I really don't care if it's not
> dracut, just so long as I am able to get the job done.
> 
> To me, the most valuable reason to do NFS root is to be able to have multiple
> diskless systems running identical operating systems, with the exception of
> configuration files for hostname, ip, ect. A single 'yum --install-root=...
> update' from the NFS server would update all systems at the same time. I am not
> as concerned with making sure that the root filesystem is read-only, as I am
> with making sure that the majority of the system's root directory is shared
> between "clients" to save on storage as well as time on some Administrative
> tasks.

I'm having the same problem and can find no documentation on how to setup/use /etc/sysconfig/readonly-root, /etc/rwtab, and /etc/statetab. Do you have any guidance or can you point me to any documentation?
Comment 27 Harald Hoyer 2010-09-06 03:30:11 EDT
The only thing, I could find was:

http://people.redhat.com/dmalcolm/stateless/stateless-linux-HOWTO-en/
Comment 28 Harald Hoyer 2010-09-06 03:30:59 EDT
(In reply to comment #27)
> The only thing, I could find was:
> 
> http://people.redhat.com/dmalcolm/stateless/stateless-linux-HOWTO-en/

totally outdated :-/
Comment 29 Kai Meyer 2010-09-07 12:44:51 EDT
Is there any hope we'll see a RHEL6 solution to parity the RHEL5 features we've talked about?
Comment 31 releng-rhel@redhat.com 2010-11-11 10:36:36 EST
Red Hat Enterprise Linux 6.0 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.

Note You need to log in before you can comment on or make changes to this bug.