Bug 607554 - java-1.6.0-openjdk won't work with libjpeg-turbo due hardcoded "Requires: libjpeg = 6b"
Summary: java-1.6.0-openjdk won't work with libjpeg-turbo due hardcoded "Requires: lib...
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: java-1.6.0-openjdk
Version: rawhide
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Deepak Bhole
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-06-24 11:10 UTC by Adam Tkac
Modified: 2013-04-30 23:46 UTC (History)
10 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2011-09-13 07:54:06 UTC


Attachments (Terms of Use)

Description Adam Tkac 2010-06-24 11:10:22 UTC
Description of problem:
There is Fedora 14 accepted feature called "libjpeg-turbo" (http://fedoraproject.org/wiki/Features/libjpeg-turbo); libjpeg will be replaced by libjpeg-turbo package.

java-1.6.0-openjdk directly requires libjpeg so it will be broken because libjpeg will disappear. Please remove this hardcoded requirement, rpm auto-dependency extractor should automatically add libjpeg.so dependency.

Version-Release number of selected component (if applicable):
java-1.6.0-openjdk-1.6.0.0-39.b18.fc14
  
Actual results:
specfile contains Requires: libjpeg = 6b

Expected results:
no direct requirement for libjpeg

Additional info:
https://bugzilla.redhat.com/show_bug.cgi?id=600243#c40

Comment 1 Adam Tkac 2010-06-28 12:58:09 UTC
Just for information, the libjpeg-turbo library has been built and replaced libjpeg library in rawhide (https://bugzilla.redhat.com/show_bug.cgi?id=600243#c47).

Comment 2 Bug Zapper 2010-07-30 12:12:58 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 14 development cycle.
Changing version to '14'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 3 Andrew John Hughes 2011-09-13 01:56:21 UTC
I presume this has been fixed and can be closed?

Comment 4 Adam Tkac 2011-09-13 07:54:06 UTC
(In reply to comment #3)
> I presume this has been fixed and can be closed?

I think so because libjpeg-turbo now provides libjpeg.


Note You need to log in before you can comment on or make changes to this bug.