Bug 607554 - java-1.6.0-openjdk won't work with libjpeg-turbo due hardcoded "Requires: libjpeg = 6b"
java-1.6.0-openjdk won't work with libjpeg-turbo due hardcoded "Requires: lib...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: java-1.6.0-openjdk (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Deepak Bhole
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-24 07:10 EDT by Adam Tkac
Modified: 2013-04-30 19:46 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-09-13 03:54:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Adam Tkac 2010-06-24 07:10:22 EDT
Description of problem:
There is Fedora 14 accepted feature called "libjpeg-turbo" (http://fedoraproject.org/wiki/Features/libjpeg-turbo); libjpeg will be replaced by libjpeg-turbo package.

java-1.6.0-openjdk directly requires libjpeg so it will be broken because libjpeg will disappear. Please remove this hardcoded requirement, rpm auto-dependency extractor should automatically add libjpeg.so dependency.

Version-Release number of selected component (if applicable):
java-1.6.0-openjdk-1.6.0.0-39.b18.fc14
  
Actual results:
specfile contains Requires: libjpeg = 6b

Expected results:
no direct requirement for libjpeg

Additional info:
https://bugzilla.redhat.com/show_bug.cgi?id=600243#c40
Comment 1 Adam Tkac 2010-06-28 08:58:09 EDT
Just for information, the libjpeg-turbo library has been built and replaced libjpeg library in rawhide (https://bugzilla.redhat.com/show_bug.cgi?id=600243#c47).
Comment 2 Bug Zapper 2010-07-30 08:12:58 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 14 development cycle.
Changing version to '14'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 3 Andrew John Hughes 2011-09-12 21:56:21 EDT
I presume this has been fixed and can be closed?
Comment 4 Adam Tkac 2011-09-13 03:54:06 EDT
(In reply to comment #3)
> I presume this has been fixed and can be closed?

I think so because libjpeg-turbo now provides libjpeg.

Note You need to log in before you can comment on or make changes to this bug.