Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 607602 - memory leak in modclusterd
memory leak in modclusterd
Status: CLOSED DUPLICATE of bug 618321
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: conga (Show other bugs)
5.5
x86_64 Linux
low Severity medium
: rc
: ---
Assigned To: Ryan McCabe
Cluster QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-24 09:16 EDT by Christoph
Modified: 2010-10-26 16:19 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-10-26 16:19:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Christoph 2010-06-24 09:16:57 EDT
Description of problem:

running a cluster of 16 identical nodes some of them develop a memory leak in modclusterd

memory usage on all nodes

PID %CPU %MEM    VSZ   RSS          STAT START   TIME COMMAND
6251  1.7 70.5 3855388 2764056      S<sl Jun07 428:07 modclusterd
5991  1.7 63.0 3855396 2466864      S<sl Jun07 430:43 modclusterd
5982  0.6  0.0 185944  3596         S<sl Jun08 161:42 modclusterd
6697  0.6  0.0 185912  3568         S<sl Jun08 161:47 modclusterd
6134  0.6  0.0 185880  3504         S<sl Jun08 162:09 modclusterd
6511  0.6  0.0 185900  3632         S<sl Jun08 162:30 modclusterd
7615  0.6  0.0 185912  3572         S<sl Jun08 162:17 modclusterd
5983  0.7  0.0 185892  3776         S<sl Jun08 162:53 modclusterd
6389  1.7 56.9 3855340 2229120      S<sl Jun07 435:56 modclusterd
6055  1.7 68.9 3856256 2699008      S<sl Jun07 436:03 modclusterd
5956  1.1 13.8 3855784 541168       S<sl Jun07 276:53 modclusterd
6399  0.7  0.0 185904  3160         S<sl Jun22  21:55 modclusterd
6025  1.7 57.8 3855416 2265320      S<sl Jun07 426:04 modclusterd
6531  1.3 41.8 3855684 1638876      S<sl Jun07 332:02 modclusterd
5984  1.7 67.6 3855476 2648728      S<sl Jun07 433:59 modclusterd


Version-Release number of selected component:
modcluster-0.12.0-7.el5


How reproducible:
can't reproduce. Just happens on some nodes. 

see also bug 252357 (has been closed because of lacking info, may be merged, i could not reopen the old bug)


Cluster config contains no services, cluster is only used for gfs (1 and 2). Gfs is mounted by fstab entries

<?xml version="1.0"?>
<cluster alias="foobar" config_version="42" name="foobar">
        <fence_daemon post_fail_delay="0" post_join_delay="3"/>
        <clusternodes>
                <!-- repeat node 1...3 are configured identical-->
                <clusternode name="node1" nodeid="1" votes="16">
                        <fence>
                                <method name="1">
                                        <device name="ilo" hostname="node1.example.com"/>
                                </method>
                        </fence>
                </clusternode>
                <!-- repeat node 4...16 are configured identical-->
                <clusternode name="node4" nodeid="4" votes="1">
                        <fence>
                                <method name="1">
                                        <device name="ilo" hostname="node4.example.com"/>
                                </method>
                        </fence>
                </clusternode>
        </clusternodes>
        <!-- we want at least two of the important nodes 1...3, this is the reason for expected_votes -->
        <cman expected_votes="63" two_node="0" hello_timer="5" deadnode_timeout="125">
                <multicast addr="x.x.x.x" interface="eth2"/>
        </cman>
        <fencedevices>
                <fencedevice agent="fence_ilo" login="james" name="ilo" passwd="bond" action="off"/>
        </fencedevices>
        <rm>
                <failoverdomains/>
                <resources/>
        </rm>
</cluster>
Comment 1 Ryan McCabe 2010-10-26 16:19:23 EDT

*** This bug has been marked as a duplicate of bug 618321 ***

Note You need to log in before you can comment on or make changes to this bug.