Bug 607615 - Update of Boost, hopefully to 1.44
Update of Boost, hopefully to 1.44
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: boost (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Benjamin Kosnik
Fedora Extras Quality Assurance
: FutureFeature
Depends On: 619869
Blocks: 656410
  Show dependency treegraph
 
Reported: 2010-06-24 09:41 EDT by Denis Arnaud
Modified: 2013-08-09 01:49 EDT (History)
9 users (show)

See Also:
Fixed In Version: fedora 14
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of: 529563
: 656410 (view as bug list)
Environment:
Last Closed: 2010-09-15 13:07:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Denis Arnaud 2010-06-24 09:41:00 EDT
+++ This bug was initially created as a clone of Bug #520087 +++

Boost 1.43 has been delivered so far (http://sourceforge.net/projects/boost/files/boost/1.43.0/), and Boost 1.44 should be delivered around mi-August 2010 (http://sourceforge.net/projects/boost/files/boost/1.44.0/).

Fedora 14 and Rawhide should try to ship with Boost 1.44. A Fedora feature has been submitted: https://fedoraproject.org/wiki/Features/F14Boost144
Comment 1 Serge Pavlovsky 2010-07-02 18:54:50 EDT
why not 1.45 ?
Comment 2 Denis Arnaud 2010-07-07 10:06:04 EDT
Boost 1.45 will not be available before mid-November, normally, far too late for Fedora 14.
Comment 3 Serge Pavlovsky 2010-07-08 19:44:39 EDT
boost has basically same schedule as gnome, but somehow fedora always manages to get latest gnome and obsolete boost
Comment 4 Petr Machata 2010-07-09 08:02:48 EDT
Well, I don't know about gnome, neither do I necessarily care, but Fedora 14 Feature Freeze is on 2010-07-27.  Boost 1.44 should come out 2010-08-02, so we will have to ship beta of 1.44 (due 2010-07-19) just to (barely) make Feature Freeze and then upgrade to final when it gets out (hopefully) a couple days later.

1.43 came out May 6, 1.42 Feb 2, so there's discernible three-month release cycle.  That puts 1.45 to November, way beyond Fedora 14's Final Change Deadline on 2010-10-11.  I don't see how we could deliver 1.45 in F14 without breaking every safety valve that's been put to Fedora release engineering process.
Comment 5 Serge Pavlovsky 2010-07-09 17:21:26 EDT
1.45 will be bugfix release for 1.44, if f14 will ship with 1.45, then six months later fedora boost users will miss 10 months of bugfixes, so
its not safe to use fedora boost at all
Comment 6 Serge Pavlovsky 2010-07-09 17:22:05 EDT
s/with 1.45/with 1.44/
Comment 7 Denis Arnaud 2010-07-10 22:16:05 EDT
Spec: http://denisarnaud.fedorapeople.org/boost/1.44.0/14/boost.spec
SRPM: http://denisarnaud.fedorapeople.org/boost/1.44.0/14/boost-1.44.0-1.fc13.src.rpm

That is a first try, based on the Boost 1.44 branch (http://gitorious.org/~zeuner/boost/zeuners-boost-cmake), maintained with the CMake building system thanks to Isidor Zeuner (http://lists.boost.org/boost-cmake/2010/04/0902.php, http://gitorious.org/~zeuner).

rpmlint reports the usual warnings and errors (e.g., MPI-dependent sub-packages have no post/postun scriptlets, some libraries have exit() functions, the main package should be noarch, etc.), but no more than for Boost 1.41 on Fedora 13 (e.g., https://bugzilla.redhat.com/show_bug.cgi?id=529563#c52).
Comment 8 Denis Arnaud 2010-07-11 08:30:41 EDT
Just to support Petr with some references:

(In reply to comment #4)
> Well, I don't know about gnome, neither do I necessarily care, but Fedora 14
> Feature Freeze is on 2010-07-27.
Fedora 14 release schedule: https://fedoraproject.org/wiki/Releases/14/Schedule

> Boost 1.44 should come out 2010-08-02, so we will have to ship beta of 1.44 
> (due 2010-07-19) just to (barely) make Feature Freeze and then upgrade to final > when it gets out (hopefully) a couple days later.
The Boost development and release calendar can be checked here: http://www.boost.org/development/index.html

> (Boost) 1.43 came out May 6, 1.42 Feb 2, so there's discernible three-month
> release cycle.
Boost 1.43: http://www.boost.org/users/news/version_1_43_0 (May 6th, 2010)
Boost 1.42: http://www.boost.org/users/news/version_1_42_0 (Feb. 2nd, 2010)
Boost 1.41: http://www.boost.org/users/news/version_1_41_0 (Nov. 17th, 2009)
Comment 9 Serge Pavlovsky 2010-07-11 08:48:34 EDT
i knew this before posting
i also knew http://live.gnome.org/TwoPointThirtyone 
"Aug 18 GNOME 2.31.90 beta release"

see, not only release, but even beta of gnome doesn't exist at 2010-07-27 and noone cares ?

i'd argue that boost doesn't require more testing than gnome
Comment 10 Denis Arnaud 2010-07-11 17:04:14 EDT
(In reply to comment #9)
> see, not only release, but even beta of gnome doesn't exist at 2010-07-27 and
> no one cares ?

Yes, but the beta version of Boost 1.45 should be released around early November 2010 (there is nothing about it on the official Boost roadmap: https://svn.boost.org/trac/boost/roadmap). So, it's impossible to base Fedora 14 on it, unless taking a lot of risks.

That is, of course, my understanding: it may not reflect the official view of Fedora committee (FESCo).
Comment 11 Serge Pavlovsky 2010-07-11 17:16:37 EDT
(In reply to comment #10)
> So, it's impossible to base Fedora
> 14 on it, unless taking a lot of risks.

but it is equally impossible to base fedora on current gnome, but still gnome maintainers somehow manage to do it
you can ask them, but i guess they just take "something, that in 4 months will become gnome release" and use it. and "something, that in 4 months will become boost 1.45" is called "boost 1.44 beta"

you can look at it as 1.0.45 if it will make it easier
Comment 12 Denis Arnaud 2010-07-12 02:01:08 EDT
(In reply to comment #11)
> [...] but [...] "something, that in 4 months will become boost 1.45" is called
> "boost 1.44 beta" . You can look at it as 1.45.0 if it will make it easier    

Boost 1.44 beta is due for Jul. 19th, 2010 (that is, exactly next week). So, I guess you wanted to speak about Boost 1.45 beta which, I believe, should be ready not before mid or end October 2010 (for a final release around early November 2010). At that time (around the 20th October, 2010), the final release of Fedora 14 should be out (https://fedoraproject.org/wiki/Releases/14/Schedule).

Since there is apparently no other intermediate public release of Boost (something like Boost 1.45.rc1), I do not see how we could base Fedora 14 on top of such a hypothetical version.

Moreover, we already base Fedora 14 on a beta (official) version of Boost. But we speak about Boost 1.44 beta, not Boost 1.45 beta. Does it correspond to what you wanted to say?

If we did not understand your remark, could you point us to any message having appeared officially on a Boost mailing list, mentioning an early beta release of Boost 1.45 (not after end-August 2010)?

=========
Now, if your point is that Fedora 14 should incorporate latest significant Boost patches for any Boost 1.44 bugs, be sure that we shall strive to do just that. As a reminder, for instance, Petr has just patched Boost 1.41 on Fedora 13 and Rawhide (https://bugzilla.redhat.com/show_bug.cgi?id=590205#c22), after an issue was detecting on some platforms for a game server software.
Comment 13 Serge Pavlovsky 2010-07-24 12:20:34 EDT
(In reply to comment #12)
> (In reply to comment #11)
> > [...] but [...] "something, that in 4 months will become boost 1.45" is called
> > "boost 1.44 beta" . You can look at it as 1.45.0 if it will make it easier    

s/1.45.0/1.0.45/ - last number means bugfix, not feature release

you are completely ignoring comparison with gnome

my point is: these numbers mean nothing, they are just some random numbers
just ship latest released version, it will be much better than previous released version
and when 1.46 comes out, ship it in updates. and 1.47 too

> As a reminder, for instance, Petr has just patched Boost 1.41 on Fedora
> 13 and Rawhide (https://bugzilla.redhat.com/show_bug.cgi?id=590205#c22), after
> an issue was detecting on some platforms for a game server software. 

i remember encountering this bug in autumn and it was already fixed in boost svn.
and you are fixing it in may ? just ship latest version, save your users time
Comment 14 Benjamin Kosnik 2010-07-26 16:56:24 EDT
Denis, sorry for the late comments. 

I think your strategy is sensible, and wish to help. I'm evaluating your srpm, but with a git-pulled version of the repository. I'll point you to the koji builds in a bit.

best,
benjamin
Comment 15 Benjamin Kosnik 2010-07-26 19:47:41 EDT
F13 scratch build
http://koji.fedoraproject.org/koji/taskinfo?taskID=2352410

F14 scratch build
http://koji.fedoraproject.org/koji/taskinfo?taskID=2352868

These builds look fine: let's do this rebase for F14. I'll send out the email announcement today and try to check in to devel tomorrow, assuming no problems found between now and then.

I stripped out the define->global, and runtime->run-time changes. I'm not necessarily opposed, but let's get the version bump done and then go back and do these stylistic things, ok? It will make backing out changes easier.
Comment 16 Denis Arnaud 2010-07-27 03:01:46 EDT
(In reply to comment #15)
> These builds look fine: let's do this rebase for F14. I'll send out the email
> announcement today and try to check in to devel tomorrow, assuming no problems
> found between now and then.

That sounds perfect. From the version (of Boost) you have checked out, there should be only bug fixes into final Boost 1.44 (July 31, 2010).

> I stripped out the define->global, and runtime->run-time changes. I'm not
> necessarily opposed, but let's get the version bump done and then go back and
> do these stylistic things, ok? It will make backing out changes easier.    

That's fine for me. No problem to re-apply the changes afterwards as, as you mentioned, they are cosmetic (orthographic changes silence new rpmlint warnings).
Comment 17 Benjamin Kosnik 2010-07-27 13:26:02 EDT
Done. 

See the rawhide build here:
http://koji.fedoraproject.org/koji/taskinfo?taskID=2354303

I've sent the mail to fedora-devel and the announce list. Now it's all about the rebuilds of dependent packages.
Comment 18 Denis Arnaud 2010-08-22 08:14:35 EDT
Newest rawhide build here:
http://koji.fedoraproject.org/koji/taskinfo?taskID=2416683
Comment 19 Benjamin Kosnik 2010-09-14 15:21:07 EDT
hey all, any sense keeping this open or can we close it? Rawhide and F14 are at boost-1.44, so $SUBJECT criteria seems to be achieved. 

I am triaging boost bugs, and would like to close this if it's not serving a useful purpose.
Comment 20 Denis Arnaud 2010-09-15 05:33:58 EDT
(In reply to comment #19)
> hey all, any sense keeping this open or can we close it? Rawhide and F14 are at
> boost-1.44, so $SUBJECT criteria seems to be achieved. 

We can close it. But I'm not the most objective packager :)
Comment 21 Benjamin Kosnik 2010-09-15 13:07:58 EDT
rawhide/f14 updated to boost-1.44.0 base.

Note You need to log in before you can comment on or make changes to this bug.