Bug 607731 - openssh-askpass should be a dependency
openssh-askpass should be a dependency
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virt-manager (Show other bugs)
6.0
All Linux
low Severity medium
: rc
: ---
Assigned To: Cole Robinson
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-24 12:35 EDT by Alex Williamson
Modified: 2010-06-25 13:15 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-25 13:15:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alex Williamson 2010-06-24 12:35:01 EDT
Description of problem:
yum groupinstall Virtualization*

try to connect to a remote system.  Unless you have it installed for something
else, virt-manager will fail with an error about /usr/libexec/openssh/ssh-askpass not existing.

Version-Release number of selected component (if applicable):
virt-manager-0.8.4-5.el6.noarch

How reproducible:
100%

Steps to Reproduce:
1. see description
2.
3.
  
Actual results:
fail

Expected results:
I have to go manually install extra packages to make the tool work like its supposed to.

Additional info:
Comment 2 RHEL Product and Program Management 2010-06-24 12:52:58 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 3 Cole Robinson 2010-06-25 13:15:09 EDT
It's not a dependency because it's not a hard requirement. A user may very legitimately want virt-manager for local management, but not want SSH installed on their machine. Adding the hard Requires: openssh-askpass would prevent this use case. Crappy, I know, but anything else would be abusing RPM requires.

The 'basic-desktop' comps group pulls in openssh-askpass, so if you are using your machine as a client, I'd recommend installing that group.

Note You need to log in before you can comment on or make changes to this bug.