Bug 60774 - mysql_socket set to /tmp/mysql.sock
mysql_socket set to /tmp/mysql.sock
Status: CLOSED DUPLICATE of bug 60515
Product: Red Hat Linux
Classification: Retired
Component: php (Show other bugs)
7.2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Phil Copeland
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-03-06 09:30 EST by Need Real Name
Modified: 2007-04-18 12:40 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-03-06 12:42:21 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2002-03-06 09:30:18 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.8) Gecko/20020205

Description of problem:
The new rpm php-4.0.6-12 (or php-mysql) sets mysql_socket /tmp/mysql.sock.
The default mysql rpm put the socket into /var/lib/mysql/mysql.sock
The previous php rpm set the socket to the /var/lib/mysql/mysql.sock

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.install the new php rpm 
2.try to create a database connection from php without specifying the socket
leads to an error ("cannot connect through socket /tmp/mysql.sock")
3.this leads particularily to problems with phplib ...
	

Actual Results:  error message, no database connection can be created

Expected Results:  database connection

Additional info:

everything can be patched by creating a symbolic link from
/var/lib/mysql/mysql.sock to /tmp/sock
Comment 1 Bill Peck 2002-03-06 09:54:37 EST
Just wanted to mention that I see this bug too and I came up with the same
workaround.  I hope a new php package is available soon since I imagine alot of
people will not realize how to fix this..
Comment 2 Eje Gustafsson 2002-03-06 12:42:17 EST
Just ran into the same issue myself.

a quick 
ln -s /var/lib/mysql/mysql.sock /tmp/mysql.sock

fixed the problem temporarly for now.

I think edit php.ini and edit it to
mysql.default_socket = /tmp/mysql.sock

should fix it to without having to recompile
Comment 3 Phil Copeland 2002-03-06 12:47:01 EST

*** This bug has been marked as a duplicate of 60515 ***

Note You need to log in before you can comment on or make changes to this bug.