Bugzilla will be upgraded to version 5.0 on December 2, 2018. The outage period for the upgrade will start at 0:00 UTC and have a duration of 12 hours
Bug 607756 - Firefox window not given focus after clicking links in other applications
Firefox window not given focus after clicking links in other applications
Status: CLOSED WORKSFORME
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: firefox (Show other bugs)
5.5
x86_64 Linux
low Severity medium
: rc
: ---
Assigned To: Martin Stransky
desktop-bugs@redhat.com
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-24 14:03 EDT by Philip Durbin
Modified: 2012-07-26 08:17 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-26 08:17:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Philip Durbin 2010-06-24 14:03:48 EDT
Description of problem:

Before the update to Firefox 3.6.4, when I clicked links in Thunderbird, gnome-terminal, and other applications, Firefox would be raised to become the topmost window, given focus, and go the to URL I had clicked.  Now, the Firefox window is not raised or given focus.

Version-Release number of selected component (if applicable):

firefox-3.6.4-8.el5

How reproducible:

Always

Steps to Reproduce:

1. Default install from rhel-server-5.5-x86_64-dvd.iso
2. rhn_register
3. yum -y update
4. Launch firefox
5. Launch gnome-terminal, echo "http://www.google.com"
6. Right click over http://www.google.com and click "Open link"
  
Actual results:

The Firefox window, which is behind the gnome-terminal window, goes to http://www.google.com but is not raised to become the top window or given focus.  Instead, in the taskbar (the bottom gnome-panel), the Firefox button flashes blue.

Expected results:

The Firefox window should be raised to become the top window, given focus, and go to http://www.google.com.

Additional info:

Only tested on x86_64
Comment 1 Matěj Cepl 2010-06-25 18:30:49 EDT
Could you please go to about:config (don't worry about the warning, I don't ask you to change anything) and tell me the value of browser.tabs.loadDivertedInBackground variable and whether it is in its default value (it is bold if changed), please?

Could you also attach output of the command

grep -H browser.tabs ~/.mozilla/firefox/*/prefs.js

please?

Thank you
Comment 2 Philip Durbin 2010-06-28 09:26:40 EDT
browser.tabs.loadDivertedInBackground is set to false, the default.

There is no output:

[pdurbin@rhel5 ~]$ grep -H browser.tabs ~/.mozilla/firefox/*/prefs.js
[pdurbin@rhel5 ~]$ 

I'd be curious to know if you can reproduce the problem.  For me it was easy with a default install and a "yum -y update".  Thanks for looking into this, Matej.
Comment 3 Matěj Cepl 2010-07-19 17:39:37 EDT
I can reproduce this easily and settings of various browser.tabs.*Background* variables doesn't seem to have any effect on it.
Comment 5 Robert G. 'Doc' Savage 2010-07-20 10:56:54 EDT
Before this problem appeared, clicking on a link in an Evo e-mail produced a flashing Firefox tab on the toolbar. This indicated a new tab was opening in Firefox, even though the browser itself was either minimized (in the current workspace) or open (in another workspace). Now that link is still opening in Firefox, but there's no longer any flashing indication in the toolbar. It *appears* as though clicking on the link in Evo does nothing, even though it actually *does* work. You just have to *know* to switch to Firefox. The previous behavior -- a flashing Firefox tab on the toolbar -- is really needed.

The state of browser.tabs.loadDivertedInBackground does not seem to matter.
Comment 6 Philip Durbin 2010-07-21 09:29:07 EDT
I just upgraded to firefox-3.6.7-2.el5 and the problem persists: the Firefox window is not given focus after clicking links in other applications.
Comment 7 Martin Stransky 2012-07-26 08:17:47 EDT
Works for me. Please reopen if you still see it.

Note You need to log in before you can comment on or make changes to this bug.