Bugzilla will be upgraded to version 5.0. The upgrade date is tentatively scheduled for 2 December 2018, pending final testing and feedback.
Bug 607761 - RHEL6-Snapshot: Display toggle HotKeys Fn+F8 does not generate KEY_SWITCHVIDEOMODE
RHEL6-Snapshot: Display toggle HotKeys Fn+F8 does not generate KEY_SWITCHVIDE...
Status: CLOSED DUPLICATE of bug 595763
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: xorg-x11-drv-evdev (Show other bugs)
6.0
All Linux
urgent Severity urgent
: rc
: 6.0
Assigned To: Peter Hutterer
desktop-bugs@redhat.com
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-24 14:18 EDT by Issue Tracker
Modified: 2010-06-29 21:32 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-29 21:32:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Issue Tracker 2010-06-24 14:18:00 EDT
Escalated to Bugzilla from IssueTracker
Comment 1 Issue Tracker 2010-06-24 14:18:03 EDT
Event posted on 06-22-2010 05:48pm EDT by Rezwanul_Kabir

Description of problem:

 Due to Win7 requirement of using Win+P key to switch display, all recent Dell platform BIOSen are generating the same scancodes for Fn+F8 as with Win+P. The problem is they are not mapped to the right keycode used in linux for display switching ( i.e. KEY_SWITCHVIDEOMODE).

  The scancodes for Fn+F8 and Win+P are as below:

     0xe0 0x5b 0x19    0x99 0xe0 0xdb
     [Key Press   ]    [ Key release]

   The Keycodes for Fn+F8 press and release are:

     125 press 25 press 25 release 125 release 
  
How reproducible:

Always

Steps to Reproduce:

1. Install RHEL6 Snapshot6
2. Use "showkey -s" or "showkey -k" to verify


Actual results:

1. KEY_LEFTMETA + KEY_P are produced

Expected results:

KEY_SWITCHVIDEOMODE is produced

Additional info:

This event sent from IssueTracker by dwa  [Dell-Engineering]
 issue 1051003
Comment 5 RHEL Product and Program Management 2010-06-24 14:32:59 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 7 Peter Hutterer 2010-06-29 21:32:11 EDT
Marking as duplicate of 595763.

This bug needs to be addressed in the session, not in the X driver. We don't have any knowledge in the X driver of whether a device requires a quirk or not.

*** This bug has been marked as a duplicate of bug 595763 ***

Note You need to log in before you can comment on or make changes to this bug.