Bug 607796 - Boot from SAN multipath failure
Summary: Boot from SAN multipath failure
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: device-mapper-multipath (Show other bugs)
(Show other bugs)
Version: 5.5
Hardware: x86_64 Linux
low
high
Target Milestone: rc
: ---
Assignee: LVM and device-mapper development team
QA Contact: Red Hat Kernel QE team
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-06-24 20:41 UTC by Mark Holohan
Modified: 2010-06-29 18:27 UTC (History)
13 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-29 18:27:59 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
tar of multipath.conf, modprobe.conf and lvm.conf (30.00 KB, application/x-tar)
2010-06-24 20:41 UTC, Mark Holohan
no flags Details

Description Mark Holohan 2010-06-24 20:41:56 UTC
Created attachment 426692 [details]
tar of multipath.conf, modprobe.conf and lvm.conf

Description of problem:  Hi, I've been trying without success to get boot from san via multipath working.  I follow the appropriate steps for the installation (linux mpath vnc), picked the correct multipath device, add the multipath rpm components, install goes smoothly.  After reboot I get

Seting up Logical Volume Management:  Found duplicate PV MAqUF0aK1EUReSv29Uk2Bzrk5DYCOvE: using /dev/sde2 not /dev/sda2
  2 logical volume(s) in volume group "VolGroup00" now active     [OK]
Checking filesystems
/dev/VolGroup00/LogVol00: clean, 87780/27066368 files, 1418332/27058176 blocks 
fsck.ext3: No such file or directory while trying to open /dev/mapper/mpath0p1
/dev/mapper/mapth0p1:
The superblock could not be read or does not describe a correct ext2 
filesystem.  .....


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.Reinstall using linux mpath vnc
2.Pick additional base package device-mapper-multipath since it wasn't selected
3.Install and reboot
  
Actual results:


Expected results:
Clean boot


Additional info:  Hopefully I'm not doing something stupid, but HBA bios setup looks good (Qlogic  QMH2462).  I'm attaching copies of the multipath.conf, lvm.conf and modprobe.conf created on the installed filesystem just before the install reboot.

Comment 1 Mark Holohan 2010-06-29 18:27:59 UTC
Hi,
  I feel this may still be a bug, but I've been notified by the HP storage team that the SAN storage I'm using (MSA2212fc) does not support boot from SAN (not a tested config).  That being the case, I need to find alternate storage and then retest, so I"m closing this bug up for now.
            Thanks,
                   Mark


Note You need to log in before you can comment on or make changes to this bug.