Bug 607870 - wget doesn't support 206 partial content response
wget doesn't support 206 partial content response
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: wget (Show other bugs)
5.5
All Linux
low Severity medium
: rc
: ---
Assigned To: Tomáš Hozza
BaseOS QE - Apps
:
Depends On:
Blocks: 920478
  Show dependency treegraph
 
Reported: 2010-06-24 23:57 EDT by bitserve
Modified: 2013-03-12 04:32 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 920478 (view as bug list)
Environment:
Last Closed: 2013-03-12 04:32:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNU Savannah 20416 None None None 2012-10-16 06:31:41 EDT

  None (edit)
Description bitserve 2010-06-24 23:57:07 EDT
Description of problem:

When using wget with a --header="Range: bytes=[number]-" header, wget doesn't recognize the 206 partial content response as valid and keeps retrying with:

HTTP request sent, awaiting response... 206 Partial Content
Retrying.


Version-Release number of selected component (if applicable):

GNU Wget 1.11.4 Red Hat modified

How reproducible:

Always.

Steps to Reproduce:
1. wget --header="Range: bytes=1-" http://www.redhat.com
2.
3.
  
Actual results:

--2010-06-24 22:44:27--  http://www.redhat.com/
Resolving www.redhat.com... 184.50.224.112
Connecting to www.redhat.com|184.50.224.112|:80... connected.
HTTP request sent, awaiting response... 206 Partial Content
Retrying.

--2010-06-24 22:44:28--  (try: 2)  http://www.redhat.com/
Connecting to www.redhat.com|184.50.224.112|:80... connected.
HTTP request sent, awaiting response... 206 Partial Content
Retrying.

--2010-06-24 22:44:30--  (try: 3)  http://www.redhat.com/
Connecting to www.redhat.com|184.50.224.112|:80... connected.
HTTP request sent, awaiting response... 206 Partial Content
Retrying.

Expected results:

--2010-06-24 22:44:02--  http://www.redhat.com/
Resolving www.redhat.com... 184.50.224.112
Connecting to www.redhat.com|184.50.224.112|:80... connected.
HTTP request sent, awaiting response... 206 OK
Length: 19546 (19K) [text/html]
Saving to: `index.html'

100%[===================================================================================================================================================================================================>] 19,546      --.-K/s   in 0.04s

2010-06-24 22:44:02 (537 KB/s) - `index.html' saved [19545/19546]

Additional info:

Seems to have broken after wget 1.9 and fixed with a feature addition

http://savannah.gnu.org/bugs/?func=detailitem&item_id=20416
Comment 1 Tomáš Hozza 2013-03-12 04:32:53 EDT
I am sorry, but it is now too late in the RHEL-5 release cycle.
RHEL-5.10 (the next RHEL-5 minor release) is going to be the first
production phase 2 [1] release of RHEL-5. This issue is still not
fixed in upstream. There still needs to be a wider discussion about
the proper fix. Regarding the nature of this issue, it is more a
Feature Request than a Bug. Since phase 2 we'll be addressing
only security and critical issues I am closing this bug as WONTFIX.

I cloned this issue for Fedora rawhide to keep track of it (Bug #920478)

[1] https://access.redhat.com/support/policy/updates/errata/

Note You need to log in before you can comment on or make changes to this bug.