Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 607895 - firefox.i686 should be in x86_64 repositories
firefox.i686 should be in x86_64 repositories
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: distribution (Show other bugs)
14
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Bill Nottingham
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-25 02:32 EDT by Maciej Żenczykowski
Modified: 2014-03-16 23:24 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-04-26 14:36:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Maciej Żenczykowski 2010-06-25 02:32:57 EDT
Please provide i686 version of Firefox in x86_64 repositories.
(even if it is not on the install CDs/DVD)

Reasoning: flash still works best with a 32-bit browser.  Once you download and install the i686 firefox rpm (all the dependencies of which are already in the x86_64 repos) you can get a very stable browser (run via setarch i386 firefox).

[If you want to be real clean about it, the firefox spec should probably be fixed so it pulls in pkg.${ARCH} instead of pkg for a couple of its requirements]
Comment 1 Maciej Żenczykowski 2010-11-08 00:27:51 EST
This is really annoying and should be trivial to fix.

Please?
Comment 2 Elad Alfassa 2011-04-26 11:39:35 EDT
IMO This bug should be closed as WONTFIX. Flash is non-free software, which fedora does not support. We don't do any special things to support non-free software in such way.
Unless you can find another reason to ship i686 build on firefox in x86_64 fedora, we shouldn't do it.

I'm not closing the bug though because I am not part of FESCO, FPC, QA Team or a firefox packager, and it's not up to me to decide.
Comment 3 Bill Nottingham 2011-04-26 14:36:28 EDT
That reasoning is correct. Note that nspluginwrapper.i686 does exist in the x86_64 repository for those that need this case. (And theoretically, Adobe will upgrade the 64-bit version at some point.)

Note You need to log in before you can comment on or make changes to this bug.