Bug 6079 - GMC automounting of CDROMs messes up cdrom burning
GMC automounting of CDROMs messes up cdrom burning
Status: CLOSED DEFERRED
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
6.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Alan Cox
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-10-19 03:09 EDT by Johan Walles
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-02-04 02:11:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Johan Walles 1999-10-19 03:09:29 EDT
To burn a CDROM I have to turn off auto-mounting of CDROMs
in the gnome control panel.  Otherwise, gmc (or whatever)
tries to mount the CD before the fixation phase is complete,
which in turn messes up the newly created CD.

I have this problem with a vanilla RH61 with no patches
applied, an ncr53c8xx SCSI card and a Philips CDD 2600 CDROM
writer.

Also, I don't really know whether this is a problem with
GNOME, cdrecord or something else, but I hope you do :-).
Comment 1 Bill Nottingham 1999-10-19 11:20:59 EDT
It's a problem with magicdev. You can remove it from
your gnome session if you like.
Comment 2 Owen Taylor 2000-02-03 16:15:59 EST
This is a kernel bug or misfeature. The kernel should not be
reporting the status of the device as CDS_DATA_* in response
to the CDROM_DRIVE_STATUS ioctl until the burn is finished.

I do not know enough about the process of writing a CD to
say what this would require in detail. It may require cooperation
with the writer software to fix this completely.

(magicdev is off by default now in the gnome-core we ship, but
this problem should be resolved at the source, and is not
particularly specific to magicdev. It could be closed if it
does not concern the kernel folks.)
Comment 3 Johan Walles 2000-02-04 02:11:59 EST
This happened with cdrecord release 1.8a35 if that helps.  But since my cd
writer is currently broken, I'm afraid I can't do any more testing :-(.

  Cheers //Johan
Comment 4 Alan Cox 2000-08-05 10:26:21 EDT
Magicdev needs rewriting by someone who actually read the ATAPI specifications

Note You need to log in before you can comment on or make changes to this bug.