Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 607949 - No core file was generated when RHEL 6 PV guest crashed
No core file was generated when RHEL 6 PV guest crashed
Status: CLOSED DUPLICATE of bug 523132
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: xen (Show other bugs)
5.6
All Linux
high Severity high
: rc
: ---
Assigned To: Xen Maintainance List
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-25 05:30 EDT by Yufang Zhang
Modified: 2010-11-09 07:41 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-28 13:21:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screen dump of the guest when it crashes (3.41 KB, text/plain)
2010-06-25 05:35 EDT, Yufang Zhang
no flags Details

  None (edit)
Description Yufang Zhang 2010-06-25 05:30:16 EDT
Description of problem:
For RHEL6 PV guest, no core file was generated automatically when the guest crashed, even core-dumps had been enabled in xend-config.sxp.

Version-Release number of selected component (if applicable):
kernel-xen-devel-2.6.18-194.3.1.el5
xen-libs-3.0.3-113.el5
xen-debuginfo-3.0.3-113.el5
xen-devel-3.0.3-113.el5
kernel-xen-2.6.18-194.3.1.el5
xen-3.0.3-113.el5


How reproducible:
Always.

Steps to Reproduce:
1. enable core-dumps and restart xend
2. create a RHEL 6 PV guest
3. force the guest to crash within the guest via:
echo c > /proc/sysrq-trigger
  
Actual results:
The guest does crash but no core file is generated.


Expected results:
core file should be generated automatically when the guest crashes.


Additional info:
screen dump of the guest is in the attachment.
Comment 1 Yufang Zhang 2010-06-25 05:35:01 EDT
Created attachment 426812 [details]
screen dump of the guest when it crashes
Comment 2 Lei Wang 2010-06-25 06:04:36 EDT
Same problem occur for RHEL6 HVM guest.

With same version xen package,
and kernel-xen version is:  2.6.18-194.6.1.el5
Comment 3 Andrew Jones 2010-06-28 13:21:34 EDT
To test if the host's userspace can create core files correctly, then the dump should be initiated with 'xm dump-core' or 'virsh dump'. This appears to work correctly (although crash has a problem reading PV guest dumps: bug 608779).

When initiating a crash with 'echo c > /proc/sysrq-trigger' this is testing the "kexec" path in the guest kernel. This is known not to work, see bug 523132.

I'll dup this bug against the kexec bug. If this was really a test of the host userspace, then it should be closed as NOTABUG due to using the wrong mechanism.

*** This bug has been marked as a duplicate of bug 523132 ***

Note You need to log in before you can comment on or make changes to this bug.