Bug 607976 - sosreport: error: no such option: --no-progressbar
Summary: sosreport: error: no such option: --no-progressbar
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Hardware Certification Program
Classification: Red Hat
Component: Test Suite (tests)   
(Show other bugs)
Version: 1.2
Hardware: All Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Greg Nichols
QA Contact: Guangze Bai
URL:
Whiteboard:
Keywords: Reopened
Depends On:
Blocks: 634912
TreeView+ depends on / blocked
 
Reported: 2010-06-25 10:30 UTC by Qian Cai
Modified: 2015-02-08 21:36 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
In v7 1.2, sosreport error messages were produced in info test. This issue has been fixed in v7 1.3, error messages are no longer logged in v7 info test.
Story Points: ---
Clone Of:
: 634912 (view as bug list)
Environment:
Last Closed: 2011-05-09 16:14:39 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
info test patch to filter sosreport error (443 bytes, patch)
2011-01-26 16:56 UTC, Greg Nichols
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2011:0497 normal SHIPPED_LIVE v7 bug fix and enhancement update 2011-05-09 16:11:16 UTC

Description Qian Cai 2010-06-25 10:30:26 UTC
Description of problem:
# v7 run --test reboot

chmod a+x ./runtest.sh ./info.py
./runtest.sh
/tmp/v7-info-V4xBoS/mnt/tests/V7/v7/info/info.py
<output>
Running ./info.py:
Tested OS: Red Hat Enterprise Linux 6 (Santiago)
Kernel RPM: kernel-2.6.32-37.el6
v7 version 1.2, release 7
<output name="Kernel" description="Check OS kernel build, version">
+ rpm -ql kernel-2.6.32-37.el6
Boot Parameters: ro root=/dev/mapper/VolGroup-lv_root rd_LVM_LV=VolGroup/lv_root rd_NO_LUKS rd_NO_MD rd_NO_DM LANG=en_US.UTF-8 SYSFONT=latarcyrheb-sun16 KEYBOARDTYPE=pc KEYTABLE=us crashkernel=128M rhgb quiet
<summary>PASS</summary>
</output>
<output name="Verify v7" description="Verify the v7 installation">
<summary>PASS</summary>
</output>
<output name="Modules" description="Check kernel modules">
checking modules...
<summary>PASS</summary>
</output>
<output name="System Report" description="generate system report">
Usage: sosreport [options]

sosreport: error: no such option: --no-progressbar

sosreport (version 2.1)

Version-Release number of selected component (if applicable):
v7-1.2-7.el6.noarch
sos-2.1-0.el6.noarch

Comment 1 Greg Nichols 2010-07-06 14:18:15 UTC
Did sosreport run to completion, or did it fail?

Comment 2 Qian Cai 2010-07-06 14:25:28 UTC
Sorry, don't understand. Looks like rhel6 sosreport has no such option,

# sosreport --no-progressbar

Usage: sosreport [options]

sosreport: error: no such option: --no-progressbar

# rpm -qf /usr/sbin/sosreport
sos-2.2-0.el6.noarch

Comment 3 Greg Nichols 2010-07-06 14:45:09 UTC
My question is - does the info test successfully run sosreport after the error appears?

Comment 4 Qian Cai 2010-07-06 14:53:32 UTC
I guess it did not, and I'll need to run it again to confirm.

Comment 5 Qian Cai 2010-07-14 05:58:16 UTC
Confirmed the sosreport had been successfully generated.

Comment 12 errata-xmlrpc 2010-09-20 12:13:31 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2010-0702.html

Comment 13 Jaromir Hradilek 2010-09-21 12:55:58 UTC
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Error messages are no longer logged when running the "v7 run" command.

Comment 14 Greg Nichols 2011-01-26 16:56:46 UTC
Created attachment 475439 [details]
info test patch to filter sosreport error

Comment 17 Caspar Zhang 2011-05-01 06:54:46 UTC
    Technical note updated. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    Diffed Contents:
@@ -1 +1 @@
-Error messages are no longer logged when running the "v7 run" command.+In v7 1.2, sosreport error messages were produced in info test. This issue has been fixed in v7 1.3, error messages are no longer logged in v7 info test.

Comment 18 errata-xmlrpc 2011-05-09 16:14:39 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2011-0497.html


Note You need to log in before you can comment on or make changes to this bug.