Bug 607989 - RFE: NetworkManager should detect network address conflicts
RFE: NetworkManager should detect network address conflicts
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
rawhide
All All
low Severity medium
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-25 07:12 EDT by Ferry Huberts
Modified: 2012-12-14 09:41 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-14 09:41:04 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ferry Huberts 2010-06-25 07:12:17 EDT
Description of feature request:

NetworkManager should detect network address conflicts upon bringing up interfaces and let the user decide what to do.


Last week I connected my HTC Desire Android phone to my Fedora 13 laptop and tethered it to connect to the internet. It didn't work.

After a bit of investigation this was caused by an IP address range conflict caused by the phone assigning the same network address range (192.168.100.100/24) as one of my libvirt 'private' bridges. Shutting down the offending bridge made it work (obviously)

Since I'm a network expert this was quickly found. A regular user will NOT know how to solve this problem therefore NetworkManager should detect the problem and let the user decide what to do. For example: decide what interface to shut down, bring the new interface up and shut another down or not bring the new interface up at all, etc.

This is a usability issue.
Comment 1 Ferry Huberts 2010-10-25 03:15:29 EDT
Dan,

I'd love to see this in F15 :-)
Comment 2 Ferry Huberts 2011-04-12 10:53:05 EDT
ping
Comment 3 Pavel Šimerda (pavlix) 2012-03-20 17:17:02 EDT
“This is a usability issue.“

This is probably a good idea but NM has so many more important issues that
I don't belive this is a priority now. But a warning application could probably
be prototyped separately from NetworkManager.

BTW, it is not very useful to bother non-expert users with decisions like that, so NM would have to act automatically either by stopping the older of the conflicting connections or at least prioritize the new one for routing.
Comment 4 Ferry Huberts 2012-03-20 17:39:07 EDT
My whole point is that this is something that can be handled by _any_ user very easily:

NM has detected that network X and network Y will not function correctly when active simultaneously, what do you want to do?
1- use network X
2- use network Y


how easy is that? ;-)
Comment 5 Pavel Šimerda (pavlix) 2012-03-21 04:06:16 EDT
“how easy is that? ;-)”

I understand you but I don't think it's a good idea to interrupt the user and
make him decide, if it's not absolutely necessary. NetworkManager should work without user interaction, and even has to work on servers.

Even on desktop/laptop, it is better if the networking “just works”. In some environments user network configuration may be even disabled.
Comment 6 Ferry Huberts 2012-03-21 04:14:32 EDT
agree.

then don't do this in the core, but in the gnome applet :-)

or allow something like a plugin to handle this through some sort of callback/notification.

you could then have interactive (desktop), noop (servers), etc. handlers.
Comment 7 Pavel Šimerda (pavlix) 2012-03-21 04:23:54 EDT
“or allow something like a plugin to handle this through some sort of
callback/notification.”

It could be, and it could be even configurable. I suggest moving this request in the Gnome bugzilla. As you can see, it's here since 2010. But it may happen there too, as NM needs work in many areas.
Comment 8 Ferry Huberts 2012-12-14 09:41:04 EST
moved to https://bugzilla.gnome.org/show_bug.cgi?id=690212

Note You need to log in before you can comment on or make changes to this bug.