Bugzilla will be upgraded to version 5.0. The upgrade date is tentatively scheduled for 2 December 2018, pending final testing and feedback.
Bug 608011 - 'Launcher Script' compatible group has two buttons of 'EDIT' & 'VIEW HISTORY' on connection page
'Launcher Script' compatible group has two buttons of 'EDIT' & 'VIEW HISTORY'...
Status: CLOSED WONTFIX
Product: RHQ Project
Classification: Other
Component: Core UI (Show other bugs)
3.0.0
All Linux
medium Severity medium (vote)
: ---
: ---
Assigned To: John Mazzitelli
Corey Welton
:
Depends On:
Blocks: rhq_triage
  Show dependency treegraph
 
Reported: 2010-06-25 08:04 EDT by Rajan Timaniya
Modified: 2011-03-24 09:21 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-03-24 09:21:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot (34.16 KB, image/png)
2010-06-25 08:04 EDT, Rajan Timaniya
no flags Details

  None (edit)
Description Rajan Timaniya 2010-06-25 08:04:44 EDT
Created attachment 426864 [details]
screenshot

Description of problem:
'Launcher Script' compatible group has two buttons of 'EDIT' & 'VIEW HISTORY' on connection page.

Version-Release number of selected component (if applicable):
JON 2.4 GA_QA (tag-jon-release: 42)
http://hudson-qe.rhq.rdu.redhat.com:8080/view/JON/job/tag-jon-release/42/

How reproducible:
Always

Steps to Reproduce:
1) Log-in to JON server
2) Create compatible group for 'Launcher Script'
 	Click on 'INVENTORY' -> 'CONNECTION'
  
Actual results:
There isn't any property to modify but there are two buttons for 'EDIT' and 'VIEW HISTORY'.

Expected results:
There should be single copy of 'EDIT' and 'VIEW HISTORY' button, if there is any property to modify.

Additional info:
Please refer attached screenshot.
Comment 1 Joseph Marques 2010-09-28 11:43:00 EDT
the reason this happens is because there is no config data for this type of resource.  however, instead of booting the user away from that tab to, say, summary>overview, we keep them there, and the user sees the buttons that would be at the top and the bottom of the table right next to each other.

solution: fix the resource type metadata so the config tab is invalid for this resource type.
Comment 2 John Mazzitelli 2010-09-30 09:49:31 EDT
this is going to be addressed when we move away from JSF to GWT.

I think this issue can be closed as obsolete.
Comment 3 John Mazzitelli 2011-03-24 09:21:07 EDT
this is no longer an issue because the GWT UI has separated the history view from the config editing view.

Note You need to log in before you can comment on or make changes to this bug.