Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 608072 - updated xm mem-max values not picked up by mem-set, fails with an error
updated xm mem-max values not picked up by mem-set, fails with an error
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: xen (Show other bugs)
5.4
All Linux
low Severity medium
: rc
: 5.6
Assigned To: Paolo Bonzini
Virtualization Bugs
: Regression
Depends On:
Blocks: 514500
  Show dependency treegraph
 
Reported: 2010-06-25 11:25 EDT by Paolo Bonzini
Modified: 2011-01-13 17:22 EST (History)
7 users (show)

See Also:
Fixed In Version: xen-3.0.3-114.el5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 528431
Environment:
Last Closed: 2011-01-13 17:22:30 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2011:0031 normal SHIPPED_LIVE xen bug fix and enhancement update 2011-01-12 10:59:24 EST

  None (edit)
Comment 1 Paolo Bonzini 2010-06-25 11:40:14 EDT
Due to the error message added for invalid "xm mem-set" values, it is not possible to balloon domains with "xm mem-set" beyond the initial maxmem size.
Comment 7 Yufang Zhang 2010-08-25 02:32:45 EDT
QA verify this bug on xen-3.0.3-115:

1. # xm cr /tmp/xm-test.conf memory=512 maxmem=1024
Using config file "/tmp/xm-test.conf".
Using <class 'grub.GrubConf.GrubConfigFile'> to parse /grub/menu.lst
Started domain vm1

2. # xm li vm1
Name                                      ID Mem(MiB) VCPUs State   Time(s)
vm1                                       22      512     4 r-----      5.2

# xm li vm1 -l | grep mem
    (memory 512)
    (shadow_memory 0)
    (maxmem 1024)

3. # xm mem-set vm1 1500
Error: Memory size too large. Limit is 1024 MiB
Usage: xm mem-set <Domain> <Mem>

Set the current memory usage for a domain.

4. # xm li vm1 -l | grep mem
    (memory 512)
    (shadow_memory 0)
    (maxmem 1024)

# xm li vm1
Name                                      ID Mem(MiB) VCPUs State   Time(s)
vm1                                       22      511     4 -b----     10.0

5. # xm mem-max vm1 2048
 
   # xm mem-set vm1 1500


6. # xm li vm1 -l | grep mem
    (memory 1500)
    (shadow_memory 0)
    (maxmem 2048)

# xm li vm1
Name                                      ID Mem(MiB) VCPUs State   Time(s)
vm1                                       22      512     4 -b----     10.0

7. # xm reboot vm1

8. # xm li vm1
Name                                      ID Mem(MiB) VCPUs State   Time(s)
vm1                                       23     1499     4 -b----      6.2

# xm li vm1 -l | grep mem
    (memory 1500)
    (shadow_memory 0)
    (maxmem 2048)

From Step 6, we could know that maxmem has been pick up by Xenstore, and xm mem-set doesn't fail at Step 5. After reboot, the guest is created with new memory and maxmem. 

Change this bug to VERIFIED.
Comment 9 errata-xmlrpc 2011-01-13 17:22:30 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2011-0031.html

Note You need to log in before you can comment on or make changes to this bug.