Bug 608076 - gnome sound volume applet leaves flicker on screen
Summary: gnome sound volume applet leaves flicker on screen
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: xorg-x11-server
Version: 6.0
Hardware: All
OS: Linux
low
low
Target Milestone: rc
: ---
Assignee: Adam Jackson
QA Contact: Desktop QE
URL:
Whiteboard: card_GM45
Depends On:
Blocks: 842499
TreeView+ depends on / blocked
 
Reported: 2010-06-25 15:33 UTC by Lubos Kocman
Modified: 2013-02-21 08:02 UTC (History)
4 users (show)

Fixed In Version: xorg-x11-server-1.13.0-3.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 608078 (view as bug list)
Environment:
Last Closed: 2013-02-21 08:02:40 UTC
Target Upstream Version:


Attachments (Terms of Use)
screenshot of the defect (992.29 KB, image/png)
2010-06-25 15:33 UTC, Lubos Kocman
no flags Details
Xorg.log (86.49 KB, text/plain)
2010-06-25 15:34 UTC, Lubos Kocman
no flags Details
dmesg_drm (130.02 KB, text/plain)
2010-06-29 15:17 UTC, Lubos Kocman
no flags Details
/var/log/messages (1.46 MB, application/octet-stream)
2010-06-29 15:19 UTC, Lubos Kocman
no flags Details
/var/log/messages (1.08 MB, text/plain)
2010-06-29 15:21 UTC, Lubos Kocman
no flags Details
Xorg.log (84.27 KB, text/plain)
2010-06-29 15:23 UTC, Lubos Kocman
no flags Details
flicker on screen (897.03 KB, image/png)
2012-04-12 14:30 UTC, Jiri Koten
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2013:0299 0 normal SHIPPED_LIVE xorg-x11-server bug fix and enhancement update 2013-02-20 20:35:47 UTC

Description Lubos Kocman 2010-06-25 15:33:50 UTC
Created attachment 426913 [details]
screenshot of the defect

Description of problem:

An applet which is configured to pop up on pressing hardware (volume/sound management buttons == mute, increase, decrease) is leaving flicker on dual head settings.

Version-Release number of selected component (if applicable):

RHEL 6.0-201006*
(issue appears also in fedora 13)

How reproducible:


Steps to Reproduce:
1.Obtain dual head configuration with RHEL 6.0 (Thinkpad T400 in my case)

2 Open application on each display and maximalize it (so you'll not see wallpaper) <- This is important, otherwise you'll not see the defect.

3.Point mouse to the primary display and click (decrease volume button)

4.Move mouse pointer to secondary screen and hit the same hardware button

5. Repeat multiple times points 3 and 4 and you should achieve the same defect as me on the attached screenshot.
  
Actual results:

applet will disappear and will leave  flicker on the screen.

Expected results:

applet will disappear

Additional info:

See attached Xorg.log

Comment 1 Lubos Kocman 2010-06-25 15:34:24 UTC
Created attachment 426914 [details]
Xorg.log

Comment 2 RHEL Program Management 2010-06-25 15:43:00 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.

Comment 3 Bastien Nocera 2010-06-25 16:24:51 UTC
Comment on attachment 426914 [details]
Xorg.log

Please select the correct mime-type for your attachements in the future.

Comment 4 Bastien Nocera 2010-06-25 16:27:56 UTC
2 things:
1) the volume popups leave in gnome-settings-daemon, not gnome-media
2) this is definitely not a gnome-settings-daemon, it would be lower down the stack.

I'll assign this to the intel driver.

Comment 6 Matěj Cepl 2010-06-25 23:18:51 UTC
Concerning the bug itself:

Please add drm.debug=0x04 to the kernel command line, restart computer, MAKE THE ISSUE HAPPEN, and then attach

* your X server config file (/etc/X11/xorg.conf, if available),
* output of the dmesg command, and
* system log (/var/log/messages)

to the bug report as individual uncompressed file attachments using the bugzilla file attachment link above.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.

Comment 9 Lubos Kocman 2010-06-29 15:17:56 UTC
Created attachment 427709 [details]
dmesg_drm

Comment 10 Lubos Kocman 2010-06-29 15:19:13 UTC
Created attachment 427710 [details]
/var/log/messages

/var/log/messages after boot with drm debug mode

Comment 11 Lubos Kocman 2010-06-29 15:21:57 UTC
Created attachment 427711 [details]
/var/log/messages

Shrinked messages

Comment 12 Lubos Kocman 2010-06-29 15:23:11 UTC
Created attachment 427712 [details]
Xorg.log

Comment 13 Dave Airlie 2010-07-08 00:10:58 UTC
what version of xorg-x11-drv-intel is installed?

Comment 15 RHEL Program Management 2010-07-15 14:58:51 UTC
This issue has been proposed when we are only considering blocker
issues in the current Red Hat Enterprise Linux release. It has
been denied for the current Red Hat Enterprise Linux release.

** If you would still like this issue considered for the current
release, ask your support representative to file as a blocker on
your behalf. Otherwise ask that it be considered for the next
Red Hat Enterprise Linux release. **

Comment 17 Lubos Kocman 2010-12-16 08:54:58 UTC
It is really a disturbing bug. I hope that we'll made it till 6.2 while we missed 6.0 and 6.1

Comment 18 Lubos Kocman 2011-03-29 10:21:09 UTC
Still the same problem on xorg-x11-drv-intel-2.14.0-1.el6.x86_64 (EL6.1). Will this ever be fixed?

Comment 20 RHEL Program Management 2011-10-07 16:14:20 UTC
Since RHEL 6.2 External Beta has begun, and this bug remains
unresolved, it has been rejected as it is not proposed as
exception or blocker.

Red Hat invites you to ask your support representative to
propose this request, if appropriate and relevant, in the
next release of Red Hat Enterprise Linux.

Comment 21 Adam Jackson 2011-10-20 16:48:44 UTC
Reproducible in 6.2.  Curiously, rebuilding the X server with --disable-composite makes the problem go away, so the affected code is almost certainly inside #ifdef COMPOSITE and not in the driver at all.

Moving to 6.3 radar since it's still fairly low impact, but definitely worth following up on.

Comment 22 Adam Jackson 2011-12-20 15:29:09 UTC
devel ack for 6.3

Comment 25 Jiri Koten 2012-04-12 14:30:34 UTC
Created attachment 577088 [details]
flicker on screen

Still able to reproduce in Rhel6.3, xorg-x11-server-Xorg-1.10.6-1.el6.

Just a note, this doesn't happen when compositing (in Metacity) is enabled.

Comment 32 Adam Jackson 2012-09-26 14:51:15 UTC
I'm no longer able to reproduce this in current 6.4 snapshots (xorg-x11-server-Xorg-1.13.0-3.el6).

On a 6.3 image I chased this down to the window's borderClip being implausible during exposure generation in MapWindow.  There's a relevant change in upstream xserver 1.13:

commit a5266dcb3a60587e1877f90c18552baf60b597a0
Author: Ville Syrjala <syrjala@sci.fi>
Date:   Sun Oct 9 01:11:04 2011 +0300

    composite: Update borderClip in compAllocPixmap()

Despite not explicitly running a compositor in RHEL6, the window created by the volume control is created on the synthetic ARGB visual, which triggers the server's internal automatic redirection logic; which is why I believe that commit is the cause for this being fixed in 6.4

MODIFIED

Comment 35 Lubos Kocman 2012-12-12 11:03:27 UTC
Hi,

I switched to F17 and gnome-shell does have completely different notification/graphics for volume control. So I really can't say.

Lubos

Comment 39 errata-xmlrpc 2013-02-21 08:02:40 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0299.html


Note You need to log in before you can comment on or make changes to this bug.