Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 608105 - [abrt] crash in seamonkey-2.0.5-1.fc13: Process /usr/lib64/seamonkey-2.0.5/seamonkey-bin was killed by signal 11 (SIGSEGV)
[abrt] crash in seamonkey-2.0.5-1.fc13: Process /usr/lib64/seamonkey-2.0.5/se...
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: seamonkey (Show other bugs)
13
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Gecko Maintainer
Fedora Extras Quality Assurance
abrt_hash:7448008ce824387cc1a2910669c...
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-25 12:56 EDT by long
Modified: 2010-09-17 14:58 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-09-17 14:58:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (114.13 KB, text/plain)
2010-06-25 12:56 EDT, long
no flags Details

  None (edit)
Description long 2010-06-25 12:56:16 EDT
abrt 1.1.1 detected a crash.

architecture: x86_64
Attached file: backtrace
cmdline: /usr/lib64/seamonkey-2.0.5/seamonkey-bin
comment: had two browser and 1 mail window open
component: seamonkey
crash_function: nsProfileLock::FatalSignalHandler
executable: /usr/lib64/seamonkey-2.0.5/seamonkey-bin
global_uuid: 7448008ce824387cc1a2910669cc29b305fdb759
kernel: 2.6.33.5-124.fc13.x86_64
package: seamonkey-2.0.5-1.fc13
rating: 4
reason: Process /usr/lib64/seamonkey-2.0.5/seamonkey-bin was killed by signal 11 (SIGSEGV)
release: Fedora release 13 (Goddard)

How to reproduce
-----
1. no clue
2.
3.
Comment 1 long 2010-06-25 12:56:18 EDT
Created attachment 426938 [details]
File: backtrace
Comment 2 d. johnson 2010-09-17 14:18:40 EDT
Thank you for taking the time to report this bug. Updates to this package have been released since it was first reported. If you have time to update the package and re-test, please do so and report the results here. You can obtain the updated package by typing 'yum update' or using the graphical updater, Software Update.


Disable extensions, plugins and non-default themes. Clear cookies and cache. Exit the browser completely.  Then restart the browser and attempt to replicate the crash.


You also appear to have permissions problems:

Error while mapping shared library sections:
/home/long/.mozilla/seamonkey/jsduccoa.default/extensions/{3b56bcc7-54e5-44a2-9b44-66c3ef58c13e}/components/libnstidy.so: Permission denied.


#2  <signal handler called>
No symbol table info available.
#3  0x0000000000000000 in ?? ()
No symbol table info available.
#4  0x00000000007876a5 in FindLineContainer (aFrame=0x7f475b7aa488)
    at nsTextFrameThebes.cpp:775
No locals.
#5  0x0000000000791254 in BuildTextRuns (aContext=0x7f475b888180, 
    aForFrame=0x7f475b7aa488, aLineContainer=0x0, aForFrameLine=0x0)
    at nsTextFrameThebes.cpp:967
        isValid = <value optimized out>
        backIterator = {mFrame = 0x0, mLine = {mCurrent = 0x7fff059f45e0}, 
          mInOverflowLines = 0x0}
        stopAtFrame = <value optimized out>
        mayBeginInTextRun = <value optimized out>
        block = <value optimized out>
        forwardIterator = {mFrame = 0x200000001, mLine = {
            mCurrent = 0x7fff059f4770}, mInOverflowLines = 0x2}
        nextLineFirstTextFrame = <value optimized out>
        seenTextRunBoundaryOnLaterLine = <value optimized out>
        seenStartLine = <value optimized out>
        linesAfterStartLine = <value optimized out>
        presContext = <value optimized out>
        scanner = {
          mMappedFlows = {<nsTArray<BuildTextRunsScanner::MappedFlow>> = {<nsTArray_base> = {static sEmptyHdr = {mLength = 0, mCapacity = 0, 
                  mIsAutoArray = 0}, mHdr = 0x0}, <No data fields>}, 
            mAutoBuf = "\000\236\322[G\177\000\000\000\000\000\000\377\177\000\000\000\000\000\000\001\000\000\000\260F\237\005\377\177\000\000\000T\242:8\000\000\000\000\000\000\000\000\000\360?", '\000' <repeats 22 times>"\360, ?\000\000\000\000\000\200B\300\000\000\000\000\000\200Z\300\000\000\000\000\000\000\360?", '\000' <repeats 22 times>"\360, ?", '\000' <repeats 22 times>"\360, ?", '\000' <repeats 22 times>"\360, ?", '\000' <repeats 16 times>, "6g\313\003\000\000\000\000\000\000\000\000j\000\000\000\000\000\000\000\372", '\000' <repeats 15 times>"\377, \177\000\000\000\000\000\000\001\000\000\000\200G\237\005\377\177\000\000\000\000\000\000\000\000\360?"}, 
          mLineBreakBeforeFrames = {<nsTArray<nsTextFrame*>> = {<nsTArray_base> = {static sEmptyHdr = {mLength = 0, mCapacity = 0, mIsAutoArray = 0}, 
                mHdr = 0x0}, <No data fields>}, 
            mAutoBuf = '\000' <repeats 14 times>, "v@\200\200\210[G\177\000\000\000\000\000\000\000\000\360?", '\000' <repeats 22 times>"\360, ?\000\000\000\000\000\200B\300\000\000\000\000\000\200Z\300\200\200\210[G\177\000\000\000\000\000\000\000\000\000\000@\245\344[G\177\000\000\000\251\304\221\325\006\215`\000\000\000\000\000\000\000\000\000\000e\232G\177\000\000T\242\"mG\177\000\000\000\000e\232G\177\000\000@\371\333\220G\177\000\000\000\300e\232G\177\000\000\020\241\"mG\177\000\000\030\000\000\000\000\000\000\000\000W\356\216G\177\000\000is\340\064\070", '\000' <repeats 11 times>, ",\001\000\000\021\000\000\000\060L\237\005\377\177\000\000@85eG\177\000\000\002\000\000\000\000\000\000\000\200\315\233[G\177\000\000\340\235\025\\G\177\000\000\000\000\000\000\000\000\000\000pG\237\005\377\177\000\000\215s"...}, 
          mBreakSinks = {<nsTArray<nsAutoPtr<BuildTextRunsScanner::BreakSink> >> = {<nsTArray_base> = {static sEmptyHdr = {mLength = 0, mCapacity = 0, 
                  mIsAutoArray = 0}, mHdr = 0x1}, <No data fields>}, 
            mAutoBuf = "\217\273\240:8\000\000\000\200\001c\232G\177\000\000`\201\210[G\177\000\000\211U\313\003\000\000\000\000 x\274\001\000\000\000\000\060\241\"mG\177\000\000\300c\367VG\177\000\000\000\000\000\000\000\000\000\000\022\275\240:8\000\000\000 x\274\001\000\000\000\000\300c\367VG\177\000"}, 
          mTextRunsToDelete = warning: can't find linker symbol for virtual table for `nsAutoTArray<gfxTextRun*, 5u>' value
warning:   found `nsTHashtable<nsBaseHashtableET<nsMorkReader::IDKey, nsTArray<nsCString>*> >::s_CopyEntry(PLDHashTable*, PLDHashEntryHdr const*, PLDHashEntryHdr*)' instead
{<nsTArray<gfxTextRun*>> = {<nsTArray_base> = {
                static sEmptyHdr = {mLength = 0, mCapacity = 0, 
                  mIsAutoArray = 0}, mHdr = 0x11579a0}, <No data fields>}, 
            mAutoBuf = "\214#\242:8\000\000\000\300c\367VG\177\000\000\200\315\233[G\177\000\000\240\274\245:8\000\000\000='\242:8\000\000\000\200\315\233[G\177\000"}, mLineBreaker = {
            mCurrentWord = {<nsTArray<unsigned short>> = {<nsTArray_base> = {
                  static sEmptyHdr = {mLength = 0, mCapacity = 0, 
                    mIsAutoArray = 0}, 
                  mHdr = 0x383aa5bca0}, <No data fields>}, 
              mAutoBuf = "\000\020\000\000\000\000\000\000\v<\242:8\000\000\000\060\234\303]G\177\000\000\020\241\"mG\177\000\000\300c\367VG\177\000\000\334X\241:8\000\000\000\000\000\000\000\000\000\360?\271\214\241:8\000\000\000\000\000\000\000\000\000\360?J\000\241:8\000\000\000\060\234\303]G\177\000\000\026O\241:8\000\000\000\000\000\000\000\000\000E@\000\000\000\000\000Pu@\000\000\000\000\000\000\360?", '\000' <repeats 22 times>"\360, ?\000\000\000\000\000\000E\300\000\000\000\000\000Pu\300\000\234\303]G\177\000\000\340I\237\005\377\177\000\000\000@\337kG\177\000\000Y\366\240:8", '\000' <repeats 11 times>"\300, \322d\000\000\000\000"}, 
            mTextItems = {<nsTArray<nsLineBreaker::TextItem>> = {<nsTArray_base> = {static sEmptyHdr = {mLength = 0, mCapacity = 0, mIsAutoArray = 0}, 
                  mHdr = 0x4045000000000000}, <No data fields>}, 
              mAutoBuf = "\000\000\000\000\000Pu@\354O\000\000\000\000\000\000,\337q", '\000' <repeats 11 times>"\360, ?\240\\\241[G\177\000\000\000\000\000\000\000\000\000\000\202eE\000\000\000\000"}, 
            mCurrentWordContainsComplexChar = 160 '\240', 
            mAfterBreakableSpace = 92 '\\', mBreakHere = 161 '\241'}, 
          mCurrentFramesAllSameTextRun = 0x0, mContext = 0x7f476bdf4000, 
          mLineContainer = 0x0, mLastFrame = 0x71de60, 
          mCommonAncestorWithLastFrame = 0x0, mMaxTextLength = 0, 
          mDoubleByteText = 0 '\000', mBidiEnabled = 0 '\000', 
          mStartOfLine = 0 '\000', mSkipIncompleteTextRuns = 0 '\000', 
          mCanStopOnThisLine = 94 '^', mNextRunContextInfo = 195 '\303', 
          mCurrentRunContextInfo = 100 'd'}
#6  0x00000000007916d3 in nsTextFrame::EnsureTextRun (this=0x7f475b7aa488, 
    aReferenceContext=<value optimized out>, aLineContainer=0x0, aLine=0x0, 
    aFlowEndInTextRun=0x0) at nsTextFrameThebes.cpp:1966
        userData = <value optimized out>
        direction = <value optimized out>
        emptySkipChars = {mList = {mRawPtr = 0x0}, mShortcuts = {
            mRawPtr = 0x0}, mListLength = 0, mCharCount = 0}
#7  0x0000000000796247 in nsTextFrame::PaintText (this=0x7f475b7aa488, 
    aRenderingContext=0x7f475b99d2e0, aPt=..., aDirtyRect=...)
    at nsTextFrameThebes.cpp:4499
        iter = {mSkipChars = 0x0, mOriginalStringOffset = 7323461, 
          mSkippedStringOffset = 0, 
          mOriginalStringToSkipCharsOffset = 1692443392, 
          mListPrefixLength = 32583, mListPrefixCharCount = 0, 
          mListPrefixKeepCharCount = 0}
        textPaintStyle = {mFrame = 0x7f479a705668, mPresContext = 0x45872d, 
          mInitCommonColors = 17 '\021', mInitSelectionColors = 0 '\000', 
          mSelectionStatus = 0, mSelectionTextColor = 32767, 
          mSelectionBGColor = 4547970, mSufficientContrast = 0, 
          mFrameBackgroundColor = 0, mIMEStyle = {{mInit = 0, 
              mTextColor = 1536937184, mBGColor = 32583, 
              mUnderlineColor = 986154592, mUnderlineStyle = 56 '8'}, {
              mInit = 3, mTextColor = 0, mBGColor = 300, mUnderlineColor = 0, 
              mUnderlineStyle = 17 '\021'}, {mInit = 0, 
              mTextColor = 94326640, mBGColor = 32767, 
              mUnderlineColor = 983712834, mUnderlineStyle = 56 '8'}, {
              mInit = 1697986624, mTextColor = 32583, mBGColor = 983612791, 
              mUnderlineColor = 56, mUnderlineStyle = 0 '\000'}}, 
          mIMEUnderlineRelativeSize = 0}
        provider = {<gfxTextRun::PropertyProvider> = {
            _vptr.PropertyProvider = 0x4042800000000000}, 
          mTextRun = 0x4075400000000000, mFontGroup = 0x4072c00000000000, 
          mFontMetrics = {<nsCOMPtr_base> = {
              mRawPtr = 0x4031000000000000}, <No data fields>}, 
          mTextStyle = 0x7f4765353988, mFrag = 0x7f4765353840, 
          mLineContainer = 0x0, mFrame = 0x7f475b9bcce0, mStart = {
            mSkipChars = 0x7fff059f4be0, mOriginalStringOffset = 94325712, 
            mSkippedStringOffset = 32767, 
            mOriginalStringToSkipCharsOffset = 94326640, 
            mListPrefixLength = 32767, mListPrefixCharCount = 983755592, 
            mListPrefixKeepCharCount = 56}, mTempIterator = {
            mSkipChars = 0x4fb0000008ac, mOriginalStringOffset = 18000, 
            mSkippedStringOffset = 1020, 
            mOriginalStringToSkipCharsOffset = 2220, 
            mListPrefixLength = 20400, mListPrefixCharCount = 18000, 
            mListPrefixKeepCharCount = 1020}, mTabWidths = 0x4fb0000008ac, 
          mLength = 18000, mWordSpacing = 0, 
          mLetterSpacing = 9.2349256822808651e-311, 
          mJustificationSpacing = 3.7944241600607735e-319, 
          mHyphenWidth = 9.2349257202251067e-311, 
          mOffsetFromBlockOriginForTabs = 6.9140988857021468e-310, 
          mReflowing = 64 '@'}
        ctx = <value optimized out>
        framePt = {x = 0, y = 6.9141827589434897e-310}
        textBaselinePt = {x = 0, y = 1.1931774314405675e-312}
        dirtyRect = {pos = {x = 6.9141894942238422e-310, 
            y = 6.9531482685890048e-310}, size = {
            width = 6.9141748140884611e-310, 
            height = 6.9531482685803093e-310}}
        advanceWidth = 6.9531482685810998e-310
        foregroundColor = {r = 6.9141825055067855e-310, 
          g = 2.1220046841468975e-314, b = 6.9531482685724042e-310, 
          a = 6.9141827589506043e-310}
        textStyle = <value optimized out>
#8  0x0000000000796775 in nsDisplayText::Paint (this=0x7f476bac3138, 
    aBuilder=<value optimized out>, aCtx=0x7f475b99d2e0, aDirtyRect=...)
    at nsTextFrameThebes.cpp:3775
No locals.
#9  0x0000000000b85662 in nsDisplayList::Paint (this=<value optimized out>, 




-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 3 long 2010-09-17 14:36:55 EDT
I've found that most of my crashes can be fixed by having

WindowlessDisable=true

in /etc/adobe/mms.cfg

since Adobe Flash Player is a bit crappy.  We can close this bug.
Comment 4 d. johnson 2010-09-17 14:58:04 EDT
Unfortunately, crash here happened in the binary-only flash player for which we don't have any source code, so unfortunately we cannot help you with it.

Closing as CANTFIX (because that's our situation)



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Note You need to log in before you can comment on or make changes to this bug.