Bug 608135 - RFE: asynchronous (group) plugin configuration update
RFE: asynchronous (group) plugin configuration update
Status: CLOSED CURRENTRELEASE
Product: RHQ Project
Classification: Other
Component: Configuration (Show other bugs)
3.0.0
All All
high Severity high (vote)
: ---
: ---
Assigned To: RHQ Project Maintainer
Mike Foley
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-25 15:17 EDT by Jay Shaughnessy
Modified: 2014-05-29 17:08 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-05-29 17:08:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jay Shaughnessy 2010-06-25 15:17:28 EDT
See https://bugzilla.redhat.com/show_bug.cgi?id=600543, an excerpt:

"...the more I thought about this and discussed with others this sort of snowballed into a discussion of why plugin config updates are synchronous, and group updates sequential, as opposed to asynch and parallel.  From discussions with jmarques it seems the reason for the synchronous approach may no longer apply, in short it was done for gui limitations and user experience reasons.

So, my recommendation here is that we change plugin config update to be
asynch, and as such change the impl to mirror resource config updates,
marshalled with timeout logic applied by quartz jobs.

Making this change will prevent us from needing to do some fairly complex work
to properly solve this issue [600543], which would entail some questionable timeout logic (hard to guess what it should be given the sequential application to N resources), or possibly individual quartz jobs for each update.  There are
server shutdown/crash/HA issues that make some of this non-trivial."


So, in short, with newer gui capabilities, like in place updates, I think we should make this change to both speed up group plugin config update by making it parallel and simplify our (group) config update logic by making plugin and resource config update handling analogous.

Note You need to log in before you can comment on or make changes to this bug.