Bug 608254 - [abrt] crashing with unprotected vcl calls in multiple threads
Summary: [abrt] crashing with unprotected vcl calls in multiple threads
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: openoffice.org   
(Show other bugs)
Version: 13
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
Assignee: David Tardon
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:67276e1af175e65ed1f730b24b9...
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-06-26 12:27 UTC by BenTrein
Modified: 2010-09-13 12:32 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-09-13 12:32:21 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (80.94 KB, text/plain)
2010-06-26 12:27 UTC, BenTrein
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenOffice.org 110567 None None None Never

Description BenTrein 2010-06-26 12:27:15 UTC
abrt 1.1.1 detected a crash.

architecture: x86_64
Attached file: backtrace
cmdline: /usr/lib64/openoffice.org3/program/swriter.bin -writer file:///home/bentrein/Dropbox/Writing/Health%20Detector/026%20Nieuw.odt
component: openoffice.org
crash_function: OutputDevice::ImplLayout
executable: /usr/lib64/openoffice.org3/program/swriter.bin
global_uuid: 67276e1af175e65ed1f730b24b9553ae52bf8ac7
kernel: 2.6.33.5-112.fc13.x86_64
package: openoffice.org-writer-1:3.2.0-12.24.fc13
rating: 4
reason: Process /usr/lib64/openoffice.org3/program/swriter.bin was killed by signal 11 (SIGSEGV)
release: Fedora release 13 (Goddard)

How to reproduce
-----
1. Have a OOo Writer document open.
2. Double Click on the Dutch Language dictionary .oxt file (from the Desktop); not the main one, but the Beta of OpenTaal.org
3.

Comment 1 BenTrein 2010-06-26 12:27:21 UTC
Created attachment 427065 [details]
File: backtrace

Comment 2 Caolan McNamara 2010-06-26 14:45:01 UTC
caolanm->dtardon: This is the same class of problem you looked at before, with the theoretical fix of http://qa.openoffice.org/issues/show_bug.cgi?id=110567

Maybe the above how-to might allow it to be reproduced and test that theory, thread 7 vs thread 1

Comment 3 Caolan McNamara 2010-09-13 12:32:21 UTC
Seems to be the same basic problem, though I wasn't able to exactly reproduce it


Note You need to log in before you can comment on or make changes to this bug.