Bug 608283 - [abrt] crash in system-config-printer-1.2.2-4.fc13: jobviewer.py:243:cancelJob_error:TypeError: descriptor 'cancelJob' requires a 'cups.Connection' object but received a 'NoneType'
Summary: [abrt] crash in system-config-printer-1.2.2-4.fc13: jobviewer.py:243:cancelJo...
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: system-config-printer   
(Show other bugs)
Version: 13
Hardware: i686 Linux
low
medium
Target Milestone: ---
Assignee: Tim Waugh
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:9b36402d
Keywords:
: 611264 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-06-26 16:03 UTC by Ulrich Walczak
Modified: 2010-09-15 07:17 UTC (History)
5 users (show)

Fixed In Version: system-config-printer-1.2.4-2.fc14
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-09-15 05:28:02 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (1.21 KB, text/plain)
2010-06-26 16:03 UTC, Ulrich Walczak
no flags Details

Description Ulrich Walczak 2010-06-26 16:03:16 UTC
abrt 1.1.1 detected a crash.

architecture: i686
cmdline: python /usr/share/system-config-printer/applet.py
component: system-config-printer
executable: /usr/share/system-config-printer/applet.py
kernel: 2.6.33.5-124.fc13.i686.PAE
package: system-config-printer-1.2.2-4.fc13
reason: jobviewer.py:243:cancelJob_error:TypeError: descriptor 'cancelJob' requires a 'cups.Connection' object but received a 'NoneType'
release: Fedora release 13 (Goddard)

backtrace
-----
jobviewer.py:243:cancelJob_error:TypeError: descriptor 'cancelJob' requires a 'cups.Connection' object but received a 'NoneType'

Traceback (most recent call last):
  File "/usr/share/system-config-printer/asyncipp.py", line 202, in send_error
    handler (self._conn, exc)
  File "/usr/share/system-config-printer/asyncipp.py", line 370, in error_handler
    return self._error (exc)
  File "/usr/share/system-config-printer/asyncipp.py", line 538, in _error
    self._client_error_handler (self._conn, exc)
  File "/usr/share/system-config-printer/asyncpk1.py", line 146, in _ipp_error_handler
    self._client_error_handler (self._conn, *args)
  File "/usr/share/system-config-printer/asyncconn.py", line 145, in <lambda>
    kwds["error_handler"] = lambda c, e: error_handler (self, e)
  File "/usr/share/system-config-printer/jobviewer.py", line 243, in cancelJob_error
    raise exc
TypeError: descriptor 'cancelJob' requires a 'cups.Connection' object but received a 'NoneType'

Local variables in innermost frame:
connection: <asyncconn.Connection object at 0x8cda06c>
exc: TypeError("descriptor 'cancelJob' requires a 'cups.Connection' object but received a 'NoneType'",)
self: <jobviewer.CancelJobsOperation instance at 0x8cd12ac>

comment
-----
I tried to set up an Epson AcuLaser 3000 printing via a router O2 Globesurfer III
No Cups Printer driver for AL3000, I tried the generic version, no luck sofar

Comment 1 Ulrich Walczak 2010-06-26 16:03:19 UTC
Created attachment 427094 [details]
File: backtrace

Comment 2 Ulrich Walczak 2010-06-28 17:29:29 UTC
Package: system-config-printer-1.2.2-4.fc13
Architecture: i686
OS Release: Fedora release 13 (Goddard)


Comment
-----
I tried to set up an Epson AcuLaser 3000 printing via a router O2 Globesurfer III
No Cups Printer driver for AL3000, I tried the generic version, no luck sofar

Comment 3 Ulrich Walczak 2010-06-28 17:30:04 UTC
Package: system-config-printer-1.2.2-4.fc13
Architecture: i686
OS Release: Fedora release 13 (Goddard)


Comment
-----
I tried to set up an Epson AcuLaser 3000 printing via a router O2 Globesurfer III
No Cups Printer driver for AL3000, I tried the generic version, no luck sofar

Comment 4 Tim Waugh 2010-06-29 13:48:10 UTC
I think this is a lack of error checking when the connection is first made in CancelJobsOperation.on_job_cancel_prompt_response.

Comment 8 Jiri Popelka 2010-07-07 13:27:33 UTC
*** Bug 611264 has been marked as a duplicate of this bug. ***

Comment 9 Fedora Update System 2010-08-26 11:52:55 UTC
system-config-printer-1.2.4-1.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/system-config-printer-1.2.4-1.fc13

Comment 10 Fedora Update System 2010-08-26 11:55:27 UTC
system-config-printer-1.2.4-1.fc14 has been submitted as an update for Fedora 14.
http://admin.fedoraproject.org/updates/system-config-printer-1.2.4-1.fc14

Comment 11 Fedora Update System 2010-08-26 18:35:48 UTC
system-config-printer-1.2.4-1.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update system-config-printer'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/system-config-printer-1.2.4-1.fc14

Comment 12 Fedora Update System 2010-09-13 18:07:57 UTC
system-config-printer-1.2.4-2.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/system-config-printer-1.2.4-2.fc14

Comment 13 Fedora Update System 2010-09-15 05:27:35 UTC
system-config-printer-1.2.4-1.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 14 Fedora Update System 2010-09-15 07:16:55 UTC
system-config-printer-1.2.4-2.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.